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1 Introduction

Navigation:  »No topics above this level«

Introduction

DMC software is designed to be a single control center for your laser machine. You can design your motion path for positioning stages and galvo scanners, control laser parameters as well as other devices like power
meters, motorized objective lens turrets, I/Os, serial port devices and others. All this is done without using G-code. By skipping the G-code conversion step, everything can be done quickly and intuitively.
You are welcome to blast your creativity with DMC, because now adapting, fixing, changing and creating new things is easier than ever.
 

Main features of DMC:
 
· Direct hardware control.

· WYSIWYG (What You See Is What You Get) window for machining preview.

· Support for both: positioning stages and galvo scanners. 

· Support for stitching (infinite field of view) with galvo scanners and stages. 

· Import of CAD files (DXF, DWG, STL, Gerber). 

· Special GUI for a specific task-optimized machine. 

· Ability to write plug-ins to support your hardware.
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2 Activation
Navigation:  »No topics above this level«

Activation

There are several versions of DMC:

· DMC PRO (full functionality, except Machine Vision)

· DMC Trial (full functionality, limited license time and/or times to run)

· DMC Demo (full functionality, hardware works only in simulation mode)

· DMC OEM

· MV Lite module (camera view integration, manual alignment, autofocus)

· MV PRO (MV Lite + automatic alignment)
 
Demo version does not require any registration or license.
All other versions require a license key, licence file or a USB dongle key issued by Direct Machining Control.
 
On the first run of DMC the Activation Window appears.
 

DMC Activation Window

Please select one of the options:

· If you have already purchased a license for DMC with a USB dongle key, select "I have a USB dongle key" and insert the key.
USB dongle key has to remain inserted all the time while DMC is running.

· If you have already purchased a license for DMC with a license key:

o Copy your ID key and send it to activation@directmachining.com. 

o When you receive your license key, select "I have a license key" and enter the key.

· If you are using DMC for evaluation purposes, send your ID key to activation@directmachining.com to request a trial license file. When you receive a trial license file, 
select "I have a Trial license file" and select the file. Each time running the software you will be reminded about the remaining duration of the trial license. 
To upgrade it to full version, contact info@directmachining.com,

mailto:activation@directmachining.com
mailto:activation@directmachining.com
mailto:info@directmachining.com
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3 User Interface
Navigation:  »No topics above this level«

User Interface

A default User Interface in DMC is divided into several sections:
 

DMC User Interface

Legend: 

¦  Ribbon Menu                               In the Ribbon Menu  you can find all the available configuration Tools . 

¦  Recipe window                           The list of commands for the recipe is displayed in sequence in the Recipe Window . 

¦   Command window                     Settings for the selected command are displayed in the Command Window . For some commands settings are divided into tabs (e.g. SHAPE, HATCHING, MARKING). 

¦  Preview window                         Visual representation of the recipe is displayed in the Preview Window . 

¦  Recipe selection bar                  Current recipe can be selected in the Recipe Selection Bar . Also new recipes can be created from here. 

¦  Status bar                                   Additional information like zoom ratio, mouse position on the preview window is displayed in the Status Bar .

10 21
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3.1 Ribbon Menu

Navigation:  User Interface  >

Ribbon Menu

In the Ribbon Menu you can find all the available configuration tools.
 

Ribbon Menu when not connected to hardware.

 

Ribbon Menu when connected to hardware.

 

Ribbon Menu during machining.

 

The Ribbon Menu is divided into these tabs:

· File - file management tools and General Settings.

· Home - most frequently used tools. 

· Control - device control tools (laser control, measurement device control, etc.). 

· Camera/Vision - camera related tools (visible only when Machine Vision module is installed and at least one Camera is enabled in the Settings). 

· Edit - CAD Object Editing tools. 

· Edit 3D - 3D CAD Object Editing tools. 

· Help - support, bug report and help tools.

3.1.1 File Menu

Navigation:  User Interface  > Ribbon Menu  >

File Menu

File management tools and General Settings.
 

File drop down Menu

 

Following Functions are accessible from a File drop down Menu

· New Recipe            Opens a New Recipe Tab. 

· Open                       Loads a saved Recipe. 

· Save                       Saves the Current Recipe to a File. 

· Save As                  Saves the Current Recipe to a new File.

· Settings                  Opens the General Settings Menu for DMC

· Samples                 A selection of sample recipes. 

· Autosave                Recent Changes to the recipes saved automatically. 

3.1.2 Home Tab

Navigation:  User Interface  > Ribbon Menu  >

Home Tab

Most frequently used tool groups are displayed in the Home Tab of the Ribbon Menu.
 

9

9 10

9 10
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Home Tab of the Ribbon Menu when connected to hardware.

 
 

Following Tool Groups and Tools are accessible in the Home Tab:

· Process             Tools related to commencing, execution, pausing or stopping the processing work flow. 

· Geometry          Tools for creating motion path for the recipe.  

· Recipe Flow      Recipe logic Tools.

· Status               Current coordinates of positioning axes. 

· Devices             Tools directly controlling the hardware. 

· View                 Tools controlling the Preview Window.

3.1.3 Control Tab

Navigation:  User Interface  > Ribbon Menu  >

Control Tab

Important Functions and Tools related to process control are situated in the Control Tab. 
 

Control Tab of the Ribbon Menu.

 
 

Following Tool Groups and Tools are accessible in the Control Tab:

· Process            Cancel button to stop the machining process. 

· Diagnostics      Tools related to observables of the machining process.   

· Galvo               Galvanoscanner related Tools.

· Control             General Control Flow functions. 

· IO                     Input/Output related  settings.

3.1.4 Camera / Vision Tab

Navigation:  Tools  >

Camera / Vision tools 

Camera / Vision Controls group contains tools used when working with cameras. 
 

 

Camera / Vision Controls Tab contains the following Tool Groups:

· Process                        Cancel button to stop the machining process.
 
· Selected Camera         Shows the currently selected camera.

· Controls                        Tools related to Camera Control.

· Calibration                    Tools related to Camera Calibration.

· Stitch                            Camera Stitching Tool. 

3.1.5 Edit Tab

Navigation:  User Interface  > Ribbon Menu  >

Edit

Edit Tab contains tool for CAD Object editing (for DXF and DWG files).
 

Edit Tab when no CAD Object is selected.

 

Edit Tab when CAD Object is selected.
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Edit Tab when Edit button is pressed.

Edit Tab contains the following Tool Groups:

· Process                        Cancel button to stop the machining process.
 
· Edit                              Tools used to edit a CAD Object. 

· Export                          Tools used to Export CAD Object. 

· Lead In Out                  Parameters for CAD Object vertex processing.

· Presets                         Preset Library. 

· Geometry                       Geometry Tools for CAD Object editing.  

3.1.6 Edit 3D Tab

Navigation:  User Interface  > Ribbon Menu  >

Edit 3D

Edit 3D Tab contains tool for 3D CAD Object editing .
 

Edit 3D Tab

Edit 3D Tab contains the following Tool Groups:

· Edit 3D                         Tools used to edit a 3D CAD Object.
 
· Create 3D                    Tools used to create simple 3D Objects. 

3.1.7 Help Tab

Navigation:  User Interface  > Ribbon Menu  >

Help Tab

Help Tab contains the Manual and information about the DMC version. 

3.2 Recipe Window

Navigation:  User Interface  >

Recipe Window

The list of commands for the recipe is displayed in sequence in this window. 
 

 
All the commands are executed during machining in the same sequence as displayed in the Recipe Window.
 

In the Recipe Window you can:

· Select a command by Left-Click.

· Move a command up/down or delete it with buttons at the top of the Recipe Window.

· Change the name of the command by Right-Click option Rename.

· Skip a command by Right-Click option Skip.

· Copy and Paste commands.

· Estimate the Recipe Time, to know how long recipe execution should take. Estimated and actual execution times may differ.
 
Some of the commands act as Parent commands and have Child commands as dependencies (e.g. Cycle is a Parent command and all the commands included in
Cycle are Child commands of Cycle).
Parent command has a triangle symbol to it, which allows to expand or collapse view of Child commands. Child commands are also indented to the right. 
There might be several layers of Parent - Child dependencies, with one Child command being a Parent command for others.
 
To convert a command to a Child command, move it up/down below the Parent command until it has right indent.
 

22

9 10

9 10

9
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3.3 Command Properties

Navigation:  User Interface  >

Command Window

Settings of the selected command are displayed in this window.
 

Command Properties Window 

           

Command Properties Window may come with some tabs for a more complex commands e.g. 3D Object. For more information see Command Settings .

3.4 Preview Window

Navigation:  User Interface  >

Preview Window

Visual representation of the recipe is displayed in the Preview Window.
 

                                                                                                          Preview Wndow

9

73

9



14 DMC User Manual 

© 2021  

                                                                                                                                                      Preview Window

                                                                                     Preview Window with imported 3D object 

 
 
 
Preview window is a WYSIWYG (What You See Is What You Get) window displaying the machining motion path. In some cases additional information like 3D models may be displayed for better visual reference.
 

View 

 

· ¦  Red lines mark the limits of your machining area.

· ¦  Black lines mark the motion trajectories where laser will be firing (marking lines). For 3D Object command, marking lines are displayed differently for better visual distinction. Orange and cyan lines on a 3D

Object will be marked as well. 

· ¦  Blue arrows represent the jump trajectories, where laser is off and no machining is performed.

· ¦  Grey dot represents the current laser position. When no motion is performed the position is 0;0;0.

· ¦  Red dot represents the current laser position and means that laser is currently firing.

· ¦  Red, ¦   green and ¦  blue lines of 1mm thickness represent the coordinate axes, X, Y and Z respectively. 

 

Controls
 
The view in the Preview Window is controlled by tools from the Ribbon Menu  View Tool Group  or mouse and keyboard.
 

· To select an object, Left-Click on it. 

· To pan the view, Right-Click and drag or use the arrow keys on your keyboard. 

· To rotate the view, hold the middle mouse button and drag. Alternatively, Ctrl + Lelf Arrow, Ctrl + Right Arrow, Ctrl + Up Arrow, Ctrl + Down Arrow key combinations can be used to rotate the 3D view by 15°. 

· To zoom in/out use the mouse wheel or Page Up / Page Down keys on your keyboard. 

· To zoom to object press the Home key on your keyboard. 

· To reset view, press the End key on your keyboard.

· To toggle the wire frame display on or off press the W key on your keyboard. 

· To assign mouse coordinates to a variable Right-Click in the Preview Window and chose Assign mpos variable in the drop down menu.

10 57
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Select and drag
 

Objects can be selected and dragged (repositioned) by using mouse. Select an object by Left-Clicking it. Mouse pointer will be moved to the closest snapping point of the object.
Move the mouse pointer while holding the left mouse button and release at the desired position. Snapping works only for the selected point of the object.
 

 

3.5 Recipe Selection Bar

Navigation:  User Interface  >

Recipe Selection Bar

Current recipe can be selected in the Recipe Selection Bar. Also new Recipe Tabs can be opened from here. 
 

                            Recipe Selection Bar

Each recipe will be opened in a separate tab. After selecting a recipe, press compile to see it in the preview window.
 

New Recipe Tabs can be opened by pressing  New tab.

3.6 Status Bar

Navigation:  User Interface  >

Status Bar

Additional information like zoom ratio, mouse position on the preview window is displayed in the Status Bar.
 

Status Bar

Click on the drop-down list to see the last notifications.

9

9
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4 File Menu
Navigation:  User Interface  > Ribbon Menu  >

File Menu

File management tools and General Settings.
 

File drop down Menu

 

Following Functions are accessible from a File drop down Menu

· New Recipe            Opens a New Recipe Tab. 

· Open                       Loads a saved Recipe. 

· Save                       Saves the Current Recipe to a File. 

· Save As                  Saves the Current Recipe to a new File.

· Settings                  Opens the General Settings Menu for DMC

· Samples                 A selection of sample recipes. 

· Autosave                Recent Changes to the recipes saved automatically. 

4.1 Settings

Navigation:  User Interface  > Ribbon Menu  >

Settings

Settings can be accessed via File Menu or by keyboard function key F12.

Note: the number and type of specific tabs will depend on the hardware setup and version of  DMC running. 
 

4.1.1 General Settings

Navigation:  Configuration and Set Up  >

General Settings

General Settings can be accessed via File Menu or by keyboard function key F12. Software related options can be accessed in general settings. 
 

9 10

9 10

81
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General Settings

General Tab

Settings File 

This section contains the path to the file with previously saved settings. Settings by default are saved in Default.hrd file in DMC install folder.
 

· Run Application In Background option enables running DMC in the background mode with no user interface. Software then can be controlled in
the remote control mode (when it is enabled). To start DMC in standard mode, find its icon in the Windows Status Bar, click on it and click 'Show
In Windowed Mode'.

· Units - drop down list allows the user to select working units (mm or inch)

· Confirm Disconnect – if toggle is enabled, Disconnect button click will cause message box to pop up to confirm disconnection form hardware.

· Confirm Run - if toggle is enabled, Run button click will cause message box to pop up to confirm execution of the machining work flow.

· Confirm Exit - if toggle is enabled, Exit button click will cause message box to pop up to confirm exiting DMC.

· Disable 3D View option removes view rotation Tools (Home Tab -> View- > Top/Front/Back,…,), disables view rotation with mouse and keyboard.

· Auto Connect Hardware on Start up - option automatically connects the hardware when the software starts. 
 

Remote Preset Library

· Use Remote Preset Library option – allows to share presets (marking, 3D printing) in a network folder between several systems. Preset library
manager will appear in the Edit Tab

 

Remote Control

· DMC can be controlled remotely by using Telnet protocol. To enable the Remote Control  click Enabled and select the desired port. 

CAD Import Settings
 

· Position for Imported Object - Absolute or Original coordinates can be chosen for positioning newly imported CAD files. Original coordinates
preserve the relation between several files created in CAD software.

· Default 3D Object Direction - depending on your application, you can select for newly imported 3D Objects to be sliced from Top to Bottom or
from Bottom to Top. Bottom to Top slicing is usually used for additive manufacturing (3D printing), while Top to Bottom slicing is mostly used
for engraving.

· Default Z Reference - select either Bottom or Top

· Sort Trajectories on import - toggle

· Optimized 3D Object View - some older graphics cards do not display certain elements in DMC. If this is the case DMC might crash when
importing or slicing 3D objects. To avoid this enable Optimized 3D Object View.

· Invert X Axis Coordinate - toggle

· Invert Y Axis Coordinate - toggle

· Invert Z Axis Coordinate - toggle

· First Slice Adjustment - field

· Slice Hatching for Individual Contour - toggle allows the user to chose whether to generate hatching for whole slice contours together or hatch
slice contours individually.

· Approximate Deviation (mm) - field

· Assign Marking Parameters to imported DXF - toggle

· Recipe Time - drop down list

· Use Progress Monitoring - toggle can be used to monitor the progress of running trajectories. 

o Trajectories to Show - dropdown used to select at which state a trajectory is visible.

§ All

§ Completed

§ Uncompleted

· Show 3D Navigation Cube - toggle
 

Polarization Control

· Enable Polarization Compensation - toggle enables using one of the rotary stages as a polarization rotating wave plate to maintain current
light polarization (e.g. perpendicular) to motion direction. 

Note: This option might not work with some  motion controllers.

3D Object Simplification on View

· Simplified 3D Object View - toggle

· Start Simplification at (Mi) - field

· Max Number of Triangles (Mi) - field

· Use Separate Process for Simplification - toggle

· Clear Cache - button 
 

In case you are working with large and complex 3D models, containing lots of triangles, software might lag when displaying those models (especially when they are rotated in Preview window). To avoid that use
'Simplified 3D Object View'. It will  simplify STL models when they are being imported, by reducing number of triangles on the object.
        

Note: this simplification affects only display of the model. Slicing is still done on original model data and is not affected by Simplification.
   
Set at what number of triangles simplification should start (0.1 Million triangles by default). Models below this value will not be simplified.
Set what should be the maximum number of triangles on a model (5 Million by default). In that case, if after initial simplification model still has more than set number of triangles it will be simplified again.
 
'Use Separate Process for Simplification' starts a separate process, so that computer resources would be used not by DMC. This is especially helpful when DMC runs on 32-bit system and therefore maximum
amount of RAM used by single process is limited.
 
Simplified models are stored in DMC /Temp folder. If a lot of models are used, it might grow large, so 'Clear Cache' might be used to free that space. Also files from that folder might be deleted manually, selecting
which files are not needed anymore.    

File name in the folder contains a special ID, compression level and original file name.

Files that have the simplified model in the Temp folder are imported much faster.

Also, use 'Clear Cache' when minimum and maximum triangle values are changed, to enable those settings for previously loaded models.

Run IO Tool When Recipe State Changes

· Recipe Running - drop down list

· Recipe Stopped - drop down list 

· Recipe Paused - drop down list

97
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Recipe Logging

 
When Recipe Logging is enabled, every time a  Recipe is executed a Log file will be created and saved for later inspection.
 
You can chose to create a new Log file or append the previous file with new information. The name of the Recipe File is the date and time of the run and the name of the recipe. 

Select whether a copy of the recipe that is being executed should be created. Recipe is saved with Recipe name and time of execution in the file name.

Polarization Control 

Enable Polarization Compensation option - enables automatic polarization compensation using rotary axis.

Compensation Type - Polarization compensation types: horizontal to vertical 45deg; full rotation 360deg.

Variables Tab

Global variables can be defined in Settings->General->Variables and defined variables are saved in hardware parameters file (*.hrd). Global variables can be accessed from any recipe. If recipe contains variable
command with same name as global variable, variable from recipe will be used. 
Variable command can be used in recipe to set value to global variable. If “Global Variable” is checked in Variable command, value will be assigned to global variable at compile or run time. If global variable doesn’t
exist, it will be created automatically. 

4.1.2 Power Meter Settings

Navigation:  Configuration and Set Up  >

Power Meter Settings

Power Meter Tab has the following settings:

· Enabled - a toggle to enable/disable the power meter. 

· Title - a user defined title for the power meter. 

· Model - the model of the power meter. 

· COM Port - an input port for the power meter. 

Measure Position Section:

· Use Different Laser Parameters for Each Laser Tool - a
toggle to use the same/different laser parameters for each tool. 

· Use Measure Position - a toggle to use Measure Position. 

· x(mm), y(mm), z(mm) - position fields. 

Wavelength's Table Section:

· Default Wavelength - drop-down list of predefined
wavelengths. 

· Wavelength(nm) - field to define the wavelength in
nanometers.

· Power Multiplier - a field to apply multiplicative weight on the
measured power. 

· Power Offset (W) - a power offset from the measured value.
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5 Home Tab
Navigation:  »No topics above this level«

Home Tab

Home Tab sections describes the tool groups available in the Ribbon Menu Home Tab.
 

  Home Tab in the Ribbon Menu

Geometry, Recipe Flow and Devices tools add a command to the recipe when used.
 
Tool groups: 

· Process

· Geometry  

· Recipe Flow  

· Devices  

· Positions

· View

5.1 Process

Navigation:  »No topics above this level«

Process

Process Tools are used to access the main functions used in the manufacturing work-flow. 

Functions available from the Process Tools Group: 

· Connect To Hardware / Disconnect. Initializes connection to the hardware enabled in the settings. 

· Compile. Compiles existing recipe commands and displays them in the Preview Window. 

· Run (available only when connected to hardware). Runs the compiled recipe on the machine. 

· Stop (available only when connected to hardware). Stops running the recipe. 

· Joystick. Activates a Virtual Joystick , if axes can be manipulated manually.

5.1.1 Virtual Joystick

Navigation:  Tools  >

Virtual Joystick

Virtual Joystick (Joystick) is a tool allowing manual control of positioning stages.
 

 

Features of Joystick: 

· Control of X and Y positioning stages. That can be done by clicking X and Y arrows. When positioning
stages are moving arrows turns green. Also it can be done by keyboard: Left/Right arrow keys for X
and Up/Down arrow keys for Y. 

· Control of Z positioning stage. Z positioning stage is controlled the same way as X and Y, just its
keyboard shortcuts are PageUp/PageDown. 

· Control of Rotary or other linear stages. Rotary stage is controlled by clicking clockwise counter
clockwise arrow buttons on Joystick or by , / . keyboard keys. 

· Homing and disabling/enabling of stage can be done using buttons near stage name. 

· Controlling speed of positioning stages. Motion speed [mm/s] for the axes can be set in a field
'Freerun/Speed' at the bottom of each axis control. It can be changed by entering a new value,
increasing/decreasing by 1 mm/s  by clicking on a small arrow on the right of the field or
increasing/decreasing x10 by clicking on x10 /10 buttons or also using +/- keyboard keys for the same
action.

· Freerun/Speed setting sets a continuous velocity for the motion while motion button is pressed. 

· Jog Distance moves axis a defined distance per motion button click with a speed set it Freerun/Speed
field. 

· Go To allows to move stages to a specific position. By default each axis interface in Joystick has a
white numerical field displaying its current position at the top. When value is changed by user, field
turns blue. Value can be reset to current axis position by pressing Esc on the keyboard. Motion to
given coordinates is executed only when Go To button is clicked. When in motion position fields turn
yellow. 

· Camera to Laser button moves positioning stages so, that position currently in the center of camera
view would be moved to laser firing position. This function works only when Camera and Laser source
are configured on the system and are not coaxial. If there is more than one camera configured, a
selection of camera used for this function has to be made in Joystick Settings. 
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· Laser to Camera button moves positioning stages so, that position currently under the laser firing
position would be moved to center of the camera view. This function works only when Camera and
Laser source are configured on the system and are not coaxial. If there is more than one camera
configured, a selection of camera used for this function has to be made in Joystick Settings. 

· Back to Start moves positioning stages to a position in which they were before starting Joystick. 

· Position buttons (P1, P2, P3, P4) allows user to store some specific frequently used positions e.g.
loading/unloading position. Motion to predefined positions can be executed by clicking on P1...P4
buttons or pressing position number (1..4) on keyboard for 1.5 s. Current position can be assigned to
button by pressing Ctrl+ position number on keyboard (1, 2, 3, 4) or can be set manually in Joystick
settings. In Joystick settings each axis can be enabled or disabled for each position e.g. if rotary axis
is disabled for P1, it will not rotate when P1 is clicked. 

· Laser Fire button starts triggering laser to fire with current power/frequency parameters. When laser is
firing button turns red. Please wear safety goggles and comply to other system specific safety
requirements when firing the laser. 

· Home button homes selected axes. 

· Settings button provides quick access to Joystick settings. 

· Assign zero position button assigns absolute stage position as (0,0,0). This function is available if
“Show 'Assign Zero Position' Option in Joystick” checkbox is checked in Settings->Joystick. This
function is available only for certain controllers. 

Joystick control Hot Keys:

Action Keyboard keys

Move X axis Left / Right

Move Y axis Up / Down

Move Z axis Page Up / Page Down

Move R1 axis , / .

Move R2 axis Shift+ , / .

Increase motion Speed/Jog
Distance x10

*

Decrease motion Speed/Jog
Distance /10

/

Increase motion Speed/Jog
Distance twice

+

Decrease motion Speed/Jog
Distance twice

-

Camera to Laser Ctrl+ Q

Laser to Camera Ctrl+ W

Back to Start Ctrl+ E

Move to Position 1 (2, 3, 4) 1 (2, 3, 4)

Assign current position to
Position 1 (2, 3, 4)

Ctrl+ 1 (2, 3, 4)

Fire Laser F

Home Axes Home

Go To Enter

Move to next Go To
coordinate field

Tab

Exit Joystick Esc

Note: Joystick control Hot Keys are active only when Joystick window is active.
 

Joystick Settings

Joystick settings allow to set predefined positions for Position 1, Position 2, etc.

Each axis can be enabled or disabled for each position e.g. if rotary axis is disabled for P1, it will not rotate when P1 is clicked.

 

5.2 Geometry

Navigation:  Tools  >

Geometry

Geometry tools are used to create motion trajectory commands for positioning stages, galvo scanners or other motion devices.
 

 
Geometry commands are added one by one by clicking on the tool in the ribbon menu.
Line, Circle, Arc, Rectangle, Polyline tools allows user to draw shapes by hand. Commands appears in Recipe Window  after drawing it or pressing enter.
 
Each added command has its own settings that appear in the Command Window .
 

Geometry tools:

· Import CAD

o CAD Object  

o 3D Object

· Line

· Circle

· Arc

· Rectangle

· Text

· 3D Projection

· Polyline

· Jump To

· Gerber Fill

· Gerber Cut

· NC Drill
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· Points

· Spiral

· Ellipse

· Barcode

· Spline

· 4D Wrapping

· Shape

5.2.1 Import CAD

Navigation:  Tools  > Geometry  >

Import CAD

Import CAD command allows user to import the following file types:

· DXF, DWG, PLT, HPGL

· 3D objects: STL, STP, STEP, IGS, IGES, CLI, LTCX, SLI, JPG, JPEG, PNG, BMP, TIF, TIFF

· Gerber Fill and Cut files: GBR, GBO, GBS, GBP, GBL, GTL, GTO, GTP, GTS, GM2, GM3

· NC Drill files: TXT, DRL

Click the Import CAD button to add a CAD file to the Recipe. You will be asked to select a file to be imported. Multiple files can be selected and imported at the same time.

Note: DXF and DWG files will add a CAD Object Command  to the recipe.
Note: STL files will add a 3D Object Command  to the recipe. 

5.2.1.1 CAD Object

Navigation:  Tools  > Geometry  >

CAD Object

CAD Object Command handles imported DXF and DWG files.

View of the imported CAD Object View of the imported CAD Object w ith Hatching visible

Settings for CAD Object Command
 

SHAPE Properties control the size and position of the imported object. See SHAPE  for more information.
 

HATCHING Properties allow the user to customize how hatching of the object is performed. See HATCHING  for more information.

MARKING Properties allow the user to customize how marking of the object is performed. See MARKING  for more information.
 

THICKNESS Properties allow the user to set parameters controlling the thickness (depth in Z axis) thus allowing to either cut or engrave an object. See
THICKNESS  for more information.

 

Samples
 

Open File -> Samples ->CAD_Object.rcp to see how Absolute/Relative/Original, Reference Point and Transform parameters change the end result.
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5.2.1.2 3D Object

Navigation:  Tools  > Geometry  >

3D Object

3D Object command handles imported 3D objects e.g. STL, STP, IGS files. Object can be imported by clicking on Import CAD button.
 
3D Object command settings are divided into tabs.
 

View of the imported 3D Object Single Slice view of a 3D Object w ith Hatching enabled

 
To prepare for machining 3D object is automatically sliced along Z axis. Default slicing distance is 1 mm. Please note, that if STL model is not prepared properly, some errors may occur especially in features that are
inside (in the volume of) the model (e.g. not closed contours, single lines). Potential errors are marked with red dots. See Slice Repair  for more information.
 

3D Object Command Properties

                                          

 
SHAPE tab contains File, Size , Position  and Transform  settings.
A saved preset of parameters containing SLICING, HATCHING, SUPPORT and MARKING information can be selected from Marking Parameters list.
 
SLICING tab contains 3D object slicing settings. 3D objects can be sliced along Z axis to prepare them for 2.5D machining like engraving or 3D printing.

· Slice Whole Object, slices whole object when selected.

· Slice Part of Object slices selected part of the object. When Slice Part of Object is selected, two additional parameters appear for: 

o Startsets position to start slicing. It is defined by object height in Z direction by millimeters (mm);

o End sets position to end slicing. It is defined by object height in Z direction by millimeters (mm). When End of slicing is selected higher than height of

the object, whole object from Start to its top will sliced.

· Slicing distance sets the distance between slices in millimeters (mm). First slice is done at the Slicing height (there is no slice at the very bottom or very
top of the object). 

· Repeat Slice repeats slice including hatching a set number of times. If Repeat parameter in MARKING is more than 1, repeat times are multiplied. 

· Change Hatching Angle by rotates hatching lines by set value in degrees (deg) between each repetition of slice. 

· Reset Hatching Angle / Continue From Last defines whether next slice will be started with hatching angle reset to original value or with the last value of
current slice + Change Hatching Angle by value. 

· Deleted Slices menu shows a list of slices that are deleted (slices can be deleted in PREVIEW tab). Selected slice may be restored by clicking Restore
Selected Slice button.

 
To hatch an object click on HATCHING tab in Tool Parameters menu. See Hatching  for more information.

 
SUPPORT tab contains settings for support generation for additive manufacturing

· Support Type selects type of supports to be used. The selection depends on installed plug-ins. Default selection "Grid" creates a grid of beams to
support overhangs. 

· Min Overhang Angle (deg) sets at minimum angle at which supports must be generated.

· Z Offset moves object up to make some space for supports for the bottom of the object. When used all of the object is on supports.

· Spacing sets distance between support beams.

· Radius/Width sets thickness of the support beam.

· Main Structure Preset sets Marking Parameters for main part of the support.

· Tip Preset sets Marking Parameters for tip of the support (part close or touching model).

· Tip Offset sets a distance between tip of the support and object for easier removal of the support.

· Raft creates a supporting plate below the object. It is usually used when object is later post processed (e.g. in an oven).
 

               

PREVIEW tab contains model and slices preview menu and allows to repair or delete slices. 

· Model view button enables and disables Model view. Multiple Slices view show all of the slice contours, but no more than number set in Max Slices to Show value. This helps to reduce number of lines displayed
and therefore RAM usage. Hatching is not displayed in Multiple Slices view. 

· Single Slice view show single slice with its hatching (if enabled). Single Slice view is automatically enabled when a specific slice is selected either on slider or in Show Slice No.: field. 

· Show Slice No.: field displays number of currently displayed slice, or lets user enter the number of slice to display. 

· Slice Z (mm) shows height of a slice in an object. 

· Slider and +/- buttons allows user to scroll through slices (mouse wheel or up/down keyboard keys may be used as well). 

· Delete Slice deletes current slice from the list and marks it gray.

· Restore Slice restores deleted slice if it is selected.

· Edit Slice allows user to repair the slice .
 
To set Marking Parameters click on MARKING in Tool Parameters menu. See Marking  for more information.

        
During Object 3D command compilation “object” variable is created. If recipe before/after slice is used, “object” variable can be used as well. “object” variable contains these fields:
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· slices_count – a number of slices object has.

· dz, slice_dz – slicing distance.

· slice_id – current slice index.

· slice_z – current slice Z position in mm (e.g. to access slice Z position, use “object.slice_z” value).

     

Slice Repair

Navigation:  Tools  > Geometry  > 3D Object  >

Slice Repair

When working with 3D objects, they are sliced and hatched for machining. However, those features heavily rely on STL model being created properly. There should be no open contours, single line walls, etc.
  
To help with badly prepared models DMC has a Slice Repair function.
 

To Repair the slice:

1. Select  plane view, select PREVIEW tab and then select the slice with an error.

Sliced STL. Note the red dots in the inside contour.

2. Zoom in to the error.

Slice error

3. Click Edit Slice in the Command Window.

a) If it is not closed contour as in example above, click left mouse button on the red dot of the line you want to change and drag it to the other one or click on the other one. The angle and length of the selected line will be changed or a
new line between too dots will be added to close the contour. To see contour properly hatched, select a different slice and then get back to current one.

b) If it is a single line, that should be deleted, select one of the red dots and drag it to another. Since, there is no contour, the line will be deleted.
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4. To restore slice, press Restore or R key.

5. To delete selected line press Delete key.

5.2.2 Line

Navigation:  Tools  > Geometry  >

Line

Line tool generates a linear motion command for positioning stages or galvo scanners.
 

Line Command Properties

Settings for Line command:
 

· Start Position:

o Absolute. Line starts at the position defined in the X1, Y1, Z1 Coordinate fields below. Jump to that position is generated automatically.

o Relative. Line starts at the current position of the device. No Jump is generated in between. This option lets easily join different motion commands into

one line.

· X1, Y1, Z1 Coordinate defines start position of the Line. Available only when Start Position Absolute is selected.

· End Position:

o Absolute. Line ends at the position defined in the X2, Y2, Z2 Coordinate fields below.

o Relative. Line end is set to a distance in X, Y, Z directions from the Line starting point set by X2, Y2, Z2 Coordinate fields.

 

 

 
Samples
 
Open File: Samples>Lines.rcp
 

5.2.3 Circle

Navigation:  Tools  > Geometry  >

Circle

Circle tool generates a circular motion path command for positioning stages or galvo scanners.
 
Circle command can be added by clicking Circle on a Geometry section in Home tab in Ribbon menu. It can be drawn manually and/or by entering specific values.
 
To draw a circle click on a Circle tool and click on selected center point on the preview screen. Size the radius and click second time to fix the Radius.
 
To enter command by parameters click Circle tool and press Enter. Enter Position of circle and Radius in the Tool Parameters menu.
 

 

Settings for Circle command:
 

· Position X, Y, Z sets a position [mm] of the circle.

o Absolute sets position [mm] in absolute coordinates.

o Relative sets a distance [mm] to the last position.
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o Reference point determines what part of circle (center, top, bottom, left, right) is set by Position.

· Radius sets the radius of the circle.

· Start Angle sets the starting position of the motion (0 to 360 deg)
 
To hatch a circle click on HATCHING tab in Tool Parameters menu. See Hatching  for more information.
 

 
To drill a hole click on DRILLING tab in Tool Parameters menu.

Drilling Settings: 

· Drilling Type:

o Layer type drills holes step by step (circle by circle) moving Z axis a distance set in dZ between each layer. In each layer circle is repeated a number of time set in Marking .

o Helix type drills holes constantly moving Z axis so a helical pattern is achieved.

· Depth (mm) a total depth of the hole (a distance Z axis will be moved).

· dZ (mm) a step between to layers in Layer type or a Z distance in which pattern goes 360 degrees in Helix type drilling.

· Offset (mm) defines an ofset for the contour for beam spot compensation. Offset can have positive and negative values.
 

Circle Command with Drilling option enabled.

 
To set individual Marking Parameters click on MARKING in Tool Parameters menu. See Marking  for more information.
 

Samples
 

Open File>Samples>Circle.rcp to see how Absolute/Relative and Reference Point settings changes the end result.

5.2.4 Arc

Navigation:  Tools  > Geometry  >

Arc

Arc tool generates an arc (part of the circle) motion path command for positioning stages or galvo scanners.
 
Arc command can be added by clicking Arc on a Geometry section in Home tab in Ribbon menu. It can be drawn manually and/or by entering specific values.
 
To draw an arc click on an Arc tool and click on selected start position on the preview screen. Select and click to set end of arc and its radius.
 
To enter command by parameters click Arc tool and press Enter. Enter Start Position, Radius and Start and End Angles in the Command Properties menu.
 

 

Settings for Arc command:
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· Position Start X, Y, Z sets starting point of the arc.

o Absolute sets position [mm] in absolute coordinates.

o Relative sets a distance [mm] to the last position.

· Clockwise/Counter Clockwise allows user to select motion direction.

· Radius [mm] sets the radius of the arc.

· Start Angle [deg] sets starting position of an arc in a circle. 0 deg is on positive X axis.

· End angle [deg] sets end position of the arc in a circle.
 
To set individual Marking Parameters click on MARKING in Command Properties meters menu. See Marking  Parameters for more information.
 
Samples
 

Open File>Samples>Arc.rcp to see how Absolute/Relative Clockwise/Counter Clockwise and Start/End angle settings changes the end result.

5.2.5 Rectangle

Navigation:  Home Tab  > Geometry  >

Rectangle

Rectangle tool generates a rectangle motion path command for positioning stages or galvo scanners.
 
Rectangle command can be added by clicking Rectangle on a Geometry section in Home tab in Ribbon menu. It can be drawn manually and/or by entering specific values.
 
To draw a rectangle click on a Rectangle tool and click on selected position for one corner on the preview screen. Click the second time to set the size and position of second corner of rectangle. When Rectangle is
drawn, Reference Point is automatically selected as the first corner.
 
To enter command by parameters click Rectangle tool and press Enter. Enter Size and Position of Rectangle in the Tool Parameters menu.
 

Rectangle Command in use

 
Rectangle has the following Command Properties: 

· Size X, Y [mm] sets size of the rectangle in X and Y directions. 

· Position X, Y, Z sets a position [mm] of the circle.

· Absolute sets position [mm] in absolute coordinates.

· Relative sets a distance [mm] to the last position. 

· Reference point determines what part of rectangle (center, top, bottom, left, right, corners) is set by Position. Default reference point is your starting corner. 

· Rotate allows to rotate [deg] rectangle around selected axis and reference point. 

· Rounding Radius allows the user to define radius of rounded corners. 
 

To hatch a rectangle click on HATCHING tab in Tool Parameters menu. See Hatching  for more information.
 
To set individual Marking Parameters click on MARKING in Command Properties menu. See Marking  Parameters for more information.
 
Samples
 

Open File>Samples>Rectangle.rcp to see how Absolute/Relative and Reference Point settings changes the end result.

5.2.6 Text

Navigation:  Tools  > Geometry  >

Text

Text tool generates text motion path.
 
Text command can be added by clicking 'More' in Geometry section in Home tab and clicking 'Text'.
 
To add a text move mouse cursor to the place where should appear. Mouse cursor represents bottom left corner of the text box.
 

· Enter text in the Text box in Command window.

· Select Font. 

· Select font parameters: 

o Italic 

o Underline 

o Strikethrough 

· Set font height in mm 

· Set Position  

· Set Transformation  

· Set Hatching parameters  

· Set Marking parameters
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Text Command Properties

Text input rules:
 
Text field can contain:

· Plain text 

· Variables 

· Math formulas and constants
 

Note: Variables, math formulas and constants are entered in braces { }. E.g. text "Speed = {speed} mm/s" will return following result "Speed = (value
of variable 'speed') mm/s". If we have a variable 'speed' with value 30 at that moment, result will be "Speed = 30 mm/s". 

Other possible entries might be:

· {speed+1} returns value of 'speed'+1 (31) 

· {speed*pi 2̂} returns value of 'speed' times square of pi
 

5.2.7 3D Projection

Navigation:  Tools  > Geometry  >

3D Projection

3D Projection command allows to project 2D geometry on 3D surface. First step would be to generate 2D pattern that will be projected on the surface. Import 2D drawing or make 2D patten using geometry

tools. Set geometry Z position to 0. Zero position will put 2D geometry on 3D surface, where negative Z position will put 2D object bellow 3D surface. 

 3D Projection On/Off option allows to turn on/off projection for positioning 2D geometry on
3D surface.

Crop to surface parameter allows to remove geometry that do not intersect with surface.

Trim by shape allows to define shape that will crop 2D projection geometry. Trim button pop-

ups form where cutting plane with offset can be defined as trim shape  

Skip vertical walls option allows to remove geometry from surface that is at steeper angle than

defined. 

3D projection with 2D galvo scanner and Z stage

2D galvo scanner in combination with Z stage can be used to mark on non-flat surface. To

achieve marking on non-flat surface, Stitching command needs to be used. Stitching command

needs to be added before geometry commands.

Galvo Scanner Field Size Z in stitching command allows to define laser focus depth (Rayleigh

length). 3D trajectories will be divided into 3D tiles that fits into galvo scanner field. Z

coordinate of the tile commands will be set to the center of the tile. 

To achieve optimal 3D trajectories marking order, set Trajectories Order to “3D” and Tile Sorting

to “None”. 
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5.2.8 Polyline

Navigation:  Tools  > Geometry  >

Polyline

Polyline tool generates a joined linear motion path commands for positioning stages or galvo scanners.
 
Polyline can be drawn by clicking on the tool and then selecting the end points for each line. To finish drawing press Enter. Then a command Polyline in Recipe window appears.
 

Polyline command with open polygon

 
In SHAPE tab, a shape can be edited.
 
A list of points in absolute coordinates are displayed in the SHAPE tab. New points can be added before selected point by clicking Insert button. Selected point can be deleted by clicking Delete button.
Coordinates of each point can be edited by double-clicking on the the value.
 
Closed Polygon, joins last point of the polyline to the first one to create a closed polygon. Closed polygon can be hatched .
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Polyline command with Close Polygon checked

 

Polyline command with Close Polygon checked and hatching enabled

 
 

5.2.9 Jump To

Navigation:  Tools  > Geometry  >

Jump To

Jump To sets an absolute or relative position for system to move with laser not firing. Device position can be defined in two ways: Laser Focus, Device.

This is usually used to move to some specific positions, e.g. unload position, camera position etc.
 

Jump To Command Properties

Position type: Laser Focus
If “Focus” is selected in "Position is", it means laser focus will move to that location. Laser focus position might be combined by Stage, Galvo Scanner and
Laser Offset (Focus=Stage+Galvo+Laser Offset). Focus position is defined by “Position Depends On” parameter, located in Settings->Laser Control. 

Laser Offset is current offset defined by selected Laser Tool (Settings->Laser Control). Laser Tool is selected by marking command or marking parameters
(MARKING tab) in geometry command. If several Laser Tools are used and Jump To needs to be done with custom Laser Tool, Laser Tool can be selected
by adding Marking command before Jump To.

If “Device” is “Stage” and “Position Is” set to “Focus”, then StageXYZ = Focus Position(X,Y,Z) – current GalvoXYZ – current LaserOffsetXYZ.
If Galvo Scanner finishes at coordinate (1;0) the next motion is done with Stage. This will cause Stage to move more in X by 1mm.

Position type: Device
If "Position is" set to "Device", then selected motion device will move to defined X, Y, Z position.

Laser Focus is a kind of global position which takes every device (stage, galvo, offset) into account, and Device changes only position of chosen devices.

5.2.10 Gerber Fill

Navigation:  Tools  > Geometry  >

Gerber Fill

Gerber Fill Command handles Gerber files (for PCB production). With Gerber Fill Tool Gerber files can be imported and hatched.
 
To prepare for etching / exposure, object usually has to be hatched.
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View with Gerber file imported

 
Gerber Fill command settings are divided to several tabs.
 
SHAPE tab contains File, Size , Position  and Transform  settings. Specific feature for Gerber Fill is Outer Contour.
Outer Contour may be needed when object has to be inverted for hatching. See the pictures below.
Outer Contour might be created automatically or imported as a separate file.
 

View with Gerber file hatched

 

Zoomed in view with Gerber file hatched
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Gerber file hatched using inversion. Outer Contour is checked

 

Gerber file hatched with inversion (zoomed)

 
To hatch an object click on HATCHING tab in Tool Parameters menu. See Hatching  for more information.
 
To set Marking parameters click on MARKING tab. See Marking  for more information.

5.2.11 Gerber Cut

Navigation:  Tools  > Geometry  >

Gerber Cut

Gerber Cut Command handles Gerber files (for PCB production). With Gerber Cut Tool Gerber files can be imported and prepared for PCB cutting.
 

Gerber Cut Command Properties

 
SHAPE tab contains File, Size , Position  and Transform  settings.
 

CUTTING tab contains cutting settings:

· Depth (mm) defines how much Z axis should be moved in total.

· dZ (mm) defines Z step size. Note that at each Z position contour will be repeated a number of times set in the Marking  tab.

· Offset (mm) generates a new contour with a set offset to compensate beam spot diameter. Offset might have positive or negative values.
 
To set Marking parameters click on MARKING tab. See Marking  for more information.
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5.2.12 NC Drill

Navigation:  Tools  > Geometry  >

NC Drill

NC Drill command is used to import NC Drill / Excellon files (usually used for PCB drilling) and prepare them for laser drilling. Only files coded in ASCII are supported (no support for binary coded files, yet).
 
NC Drill command settings are divided to tabs.
 
SHAPE tab contains File, Size , Position  and Transform  settings.
 

View with NC Drill file imported

 

NC Drill Command with layer drilling selected

 

NC Drilling file w ith Helix drilling selected

 
DRILLING tab sets parameters for drilling:

· Drilling Type:

o Layer type drills holes step by step (circle by circle) moving Z axis a distance set in dZ between each layer. In each layer circle is repeated a number of time set in Marking .

o Helix type drills holes constantly moving Z axis so a helical pattern is achieved.

· Depth (mm) a total depth of the hole (a distance Z axis will be moved).

· dZ (mm) a step between to layers in Layer type or a Z distance in which pattern goes 360 degrees in Helix type drilling.

· Offset (mm) defines an ofset for the contour for beam spot compensation. Offset can have positive and negative values.
 
To set Marking parameters click on MARKING tab. See Marking  for more information.
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5.2.13 Points

Navigation:  Tools  > Geometry  >

Points

Points command creates a matrix of points with selected size and pitch.
   
To add a Points command click on it in the Ribbon menu Home tab, Geometry group.
 
Points Command has the following properties:

· Position  of the Points matrix.

· Number Of Points In X.

· Number Of Points In Y.

· Pitch X (mm) sets distance between two points in X direction.

· Pitch Y (mm) sets distance between two points in Y direction.

· No. Of Pulses sets how many pulses laser should fire per one point.
 
To set individual Marking Parameters click on MARKING in command window. See Marking  Parameters for more information.
 

5.2.14 Spiral

Navigation:  Tools  > Geometry  >

Spiral

Spiral tool generates a spiral motion path command for positioning stages or galvo scanners.
 
Spiral command can be added by clicking More on a Geometry section in Home tab in Ribbon menu and then clicking on Spiral. Center and outer radius of the spiral can be drawn manually and/or by entering specific
values.
 
To draw a spiral click on a Spiral tool and click on selected center point on the preview screen. Size the radius and click second time to fix the Outer Radius.
 
To enter command by parameters click Spiral tool and press Enter. Enter Position of spiral reference point, Outer Radius and Starting Pitch in the Command Properties menu.
 

View with Regular Spiral drawn

 
Spiral Command has the following properties:

· Position  - sets position of the spiral.

· Inner Radius - sets an initial radius of the spiral. If Inner Radius = 0, spiral starts from the center position of the Spiral.

· Ending Pitch - sets variable pitch of the Spiral. If Ending Pitch = 0, then pitch between two spiral lines stays the same. If Ending Pitch > 0, then spiral pitch changes, starting with Starting Pitch value and
decreases/increases until it reaches Ending Pitch. Starting Pith and Ending Pitch positions change depending on whether spiral is created Outwards or Inwards.

· Pitch Step - sets pitch increments/decrements by which pitch changes when Ending Pitch > 0. Once Ending Pitch is reached, it stays the same till the last spiral strand.

· Spiral Turn Direction - sets, whether spiral is created Clockwise or Counterclockwise.

· Create Spiral Outwards/Inwards - sets whether spiral is started at the center or at the outer edge.

· Inner Circle Repeat - adds a circle in the center of the spiral when Inner Circle Repeat > 0. Radius of the circle = Inner Radius. Inner Circle Repeat value sets how many times circle will be machined before/after the
spiral. Note, that Repeat parameter in MARKING parameters multiplies Inner Circle Repeat value.

· Outer Circle Repeat - adds a circle at the outer edge of the spiral when Outer Circle Repeat > 0. Radius of the circle = Outer Radius. Outer Circle Repeat value sets how many times circle will be machined
after/before the spiral. Note, that Repeat parameter in MARKING parameters multiplies Outer Circle Repeat value.

· Rewind Spiral - creates a mirrored spiral. I.e. if there is a Clockwise Outward spiral, a Counterclockwise Inwards spiral will be added.

· Approximate Spiral by Arcs or by Lines - sets whether geometry of the spiral is described by arcs or by lines. If your motion controller supports arc motion, it is advised to approximate it by Arcs as it provide
smoother motion.
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Spiral w ith a variable pitch drawn. Set Ending Pitch > 0 to use this feature.

 

Spiral drawn with a 'Rewind Spiral' feature enabled.

 
 

 
 

5.2.15 Ellipse

Navigation:  Tools  > Geometry  >

Ellipse

Ellipse tool generates an elliptical motion path command for positioning stages or galvo scanners.
 
Ellipse command can be added by clicking More on a Geometry section in Home tab in Ribbon menu and then clicking on Ellipse.
 
To draw an ellipse click on the Ellipse tool and click on selected center point on the preview screen. Size horizontal axis (width), click left mouse button, then size vertical axis (height) and left mouse click. When drawing
horizontal axis, it can be drawn at an angle to the X axis to rotate the ellipse.
 

View with an Ellipse drawn

 
Ellipse Command has the following properties:

· Position  and reference point.

· Direction of machining - sets whether motion is done clockwise or counterclockwise.

· Width - sets width of the ellipse (first axis).

· Height - sets height of the ellipse (second axis).
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· Angle - rotates ellipse around its center.

· Approximate by Arcs or by Lines - sets whether geometry of the ellipsis is described by arcs or by lines. If your motion controller supports arc motion, it is advised to approximate it by Arcs as it provide smoother
motion.

5.2.16 Barcode

Navigation:  Tools  > Geometry  >

Barcode

Barcode Tool generates a pattern for a selected barcode / datamatrix type.
 
Barcode Command can be called by clicking More in Geometry Tool group in the Home tab of the Ribbon menu and selecting Barcode.

Barcode Command Properties

Barcode Command has the following properties: 

· Format - the format of a barcode being created. 

· Text - the text being encoded. 

Note: Only digits 0-9, uppercase letters A-Z symbols '-$%./+', SPACE and symbol '*' for start/end are allowed. For example: *123AB456+78 9*

· Mode - Point or Area mode 

· Width (mm) - the width of a barcode in millimeters. 

· Aspect Ratio - the aspect ratio of the barcode. 

· Invert Code - switch can be used to invert the barcode. 

· Margin Size (cells) - the size of barcode borders in cells  

· Position - section can be used to define the position of the barcode object. For more information refer to section Position . 

· Transfrom - section can be used to apply transformations to the barcode object. For more information refer to section Transform . 

Barcode Command Properties in Point mode

In Point mode the following options become available: 

· Dimension - multiplicity of the points for every bar.

· No of Pulses - number of pulses used to mark each point. 

· Point Sorting - schema for sorting points when marking:

o Sorted 

o Bidirectional

o Distributed 

o Not sorted 

5.2.17 Spline

Navigation:  Tools  > Geometry  >

Spline

Spline tool generates a spline marking trajectory.
 
Spline command can be added by clicking More on a Geometry section in Home tab in Ribbon menu and then clicking on Spline. Spline can only be edited by drawing it and editing is points by hand.
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View with a Spline drawn

 
Spline Command has the following properties:

· Position  - sets position of the first point of the spline.

· Closed spline - when Closed is selected, two points of the spline are joined with another spline.

· Edit Spline - turns spline editing mode. When it is on, spline points can be selected and edited. Click enter to confirm the changes. 

5.2.18 4D Wrapping

Navigation:  Tools  > Geometry  >

4D Wrapping 

The function is available under the Geometry group in the Ribbon. It allows wrapping a 2D object around the tube or cone.

 To use the function, the user adds a 4D Wrapping to the recipe and imports a 2D shape (for example .dxf) or any other 2D object. 4D Wrapping has the following options:

· Rotate around – select an axis to rotate around

· Rotary axis – the rotating axis

· Rotary Offset – if rotary should start not from zero, enter the offset here or click Get Current Position.

· Wrapping shape – either cylinder or cone

· Radius for cylinder and length with cone top radius for cone description.

Press Compile to see the result. 2D object position can be shifted by entering XY values in 2D objects Shape tab’s Position section. Also, make sure to select correct marking parameters in the 2D Objects Marking tab.
Click Run to start the process.

5.2.19 Shape Tool

Navigation:  Tools  > Geometry  >

Shape

Warning: without the 5-axis module use with care. Some of the functionality might not work and produce errors.

The Shape function is also under the Geometry group in the Ribbon. Shape allows wrapping a 2D object around any 3D shape as is demonstrated below. 

To use the function, the user adds the Shape function to the recipe. In command properties, select the 3D file. Mode must be 2.5D, 3D requires 5-axis module. Next step is to select the Surface Point in the
recipe window.

Then, in Command Properties, click the button “Edit reference point” and select two points on the 3D object’s surface that will form a plain to describe wrapping direction. Mode hast to be wrapping. 5D
option will not work without the dedicated module.

In the 2D object’s Marking tab select the marking parameters. In the Shape tab edit size and position. Click Compile to see the result and Run to execute the job.

5.3 Recipe Flow

Navigation:  Home Tools  >

Recipe Flow

Recipe Flow section describes usage of tools/commands in the Recipe Flow group in Home tab
 

 
Recipe Flow Tool Group in the Home Tab

Recipe Flow commands affects behavior of other commands during execution of recipe.
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Recipe Flow Drop Down List

Recipe Flow Commands can be called from the Recipe Flow Group, the commands are:

· 3D Printing  - combines 3D objects to control the entire printing process. 

· Variable  - creates a variable to be used instead of a specific value in Command Parameters. 

· Loop  - repeats the commands included in the cycle a defined number of times. 

· Array  - replicates the object within the command as an array (with constant or variable parameters).

· If  - executes the included commands under defined conditions. 

· Dialog . 

· Pause  - adds a pause in the recipe. 

· Marking Parameters  - sets the speed and laser triggering parameters for a section until the next Marking Parameters command is called. 

· Transform .  

· Z Map .

· Export Data .

· CAD Alignment.

· Find Corner  - uses the camera to find a corner of an object. 

· Find Edge  - uses the camera to find an edge of an object. 

· Find Large Circle  - uses the camera to find a circular object which does not fit into the camera view.

· Image Processing. 

· Alignment .

· Status.

· Chart.

· Camera Stitching. 

· Recipe  - imports a saved recipe file as a single command. 

· Note .

· Cancel Execution.

· Run And Clear.

· View Control. 

· Joystick. 

· Settings . 

· Wait. 

5.3.1 3D Printing

Navigation:  Home Tab  > Recipe Flow  >

3D Printing

3D Printing Command simplifies the usage and preparation of the STL files in 3D Object work flow.

3D Printing Command combines all the 3D Object Command Properties for imported STL files so that they can be machined together layer by layer.
 

3D Printing Command Window

3D Printing Command has the following Properties: 

Settings Tab: 

· Preset drop-down menu allows the user to load a preset with all the saved settings in SETTINGS, HATCHING, MARKING, STITCHING tabs.

· Hatching  and Marking  parameters can be set globally in 3D Printing Command for all 3D Objects or individually for each object in 3D
Object command.

 

Actions
 

For some additive manufacturing techniques specific actions need to be taken before and after each layer (e.g. distributing the material, moving
platform, etc.). To perform these actions before or after each layer save them as separate recipes and select them in the "Before Each Slice"
and "After Each Slice" fields. Different actions can be set to be executed at the start and at the end of the recipe e.g. preheating, cooling, etc.

 

Settings
 

· In some printing processes it is convenient to start printing at the current powder bed position, when powder is leveled. To do that select
Start First Slice at Current Z Position. All objects will be
positioned vertically so, that the first slice of lowest object is at current Z position. 

· Slicing of the imported objects is performed globally with a specific slice distance set to prevent printing at different heights, hitting
obstructions or destroying objects.

· Choose whether to slice the Whole height or Custom Section. 

· Z position of the objects may be adjusted by half slicing distance, so that no part of the object is lost when slicing is started not at usual
position.

Shape Smoothing 

Shape smoothing allows to have smoother edges of the slice contour. In the beginning poly lines are split into two poly lines if angle between

two segments of a poly line is larger than a specified value. This is done to preserve sharp corners of the shape (e.g. rectangle). Next

approximation or interpolation with Bezier curve is applied. Approximation tension parameter controls corner rounding strength, where zero

makes new corner almost match input corner and one makes rounded corner which will have position deviation smaller than the one defined in

“Max Deviation” field. Split 3D Model. If imported 3D model has more than one object, model can be split into several parts. If engraving

process is used, different parts will be engraved entirely before engraving the next part.
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Stitching Tab: 

Stitching Tab contains the parameters needed for manual object tile/overlay handling. 

Preview Tab: 

Preview Tab contains model and slices preview menu and allows 
to repair or delete slice

· Model view button enables and disables Model view. 

· Multiple Slices view show all of the slice contours, but no more than number set in Max Slices to Show value. This helps to reduce number of lines
displayed and therefore RAM usage. Hatching is not 
displayed in Multiple Slices view. 

· Single Slice view show single slice with its hatching (if enabled). Single Slice view is automatically enabled when a specific slice 
is selected either on slider or in Show Slice No.: field. 

· Show Slice No.: field displays number of currently displayed slice, 
or lets user enter the number of slice to display. 

· Slice Z (mm) shows height of a slice in an object. 

· Slider and +/- buttons allows user to scroll through slices (mouse 
wheel or up/down keyboard keys may be used as well).

Support Tab:

Support Tab allows the user to define various parameters needed to generate supports for a 3D printed object. 

 

3D Printing View of the entire Object

3D Printing View of a single slice

5.3.2 Variable

Navigation:  Tools  > Recipe Flow  >

Variable
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Variable is a Command in Recipe Flow which can be used to pass a value of a user defined or imported variable to part of the Recipe Flow.

Variable Command Properties Window

Variable Command has the following properties: 

· Name - user defined name of a variable. 

· Value - user defined value of a variable (default value 1). 

· Description - a text box where user can leave comments or description of a variable. 

· Create Data Array - toggle allows user to enter or import an array of data points for the variable. 

· User Input - toggle allows user input for the variable value while Recipe is running. 

· Access Variable in Other Recipes - toggle makes the variable accessible in other recipes. 

· Global Variable - toggle changes variables scope to global.  

Usage of Variable Command:

· Value of the variable can be changed within the recipe.

· Value of the variable can be calculated using a mathematical formula:

e.g. Variable c with a value: sqrt(a^2+b^2), where a and b are names of other variables will return the length of a right triangle hypotenuse, where a and b are another two sides of the same triangle.

· Variable itself can be included in formulas used for calculation of values for other variables

e.g. Value of a variable named a and the value of 0 later in the recipe can be calculated as a+1 retuning the value 1.

· Value field of a variable may also contain a text string. Text must be written in quotation marks: "text value of variable". Value field may contain both text and mathematical formulas.

· Value of a variable can be changed by RCM (remote control module), text file, Input Command (digital/analog value), user input.

Note: See Formulas and Constants  for a list of available mathematical formulas and functions which can be used on a Variable Command.

Variable Command Properties Window with Data Array

toggle enabled

Data Array Variable: 

· Values in the Data Array Variable can be defined by the user or imported as .csv or .txt files.

· To access the value in a Data Array Variable Cell use the function variablename(column_no;row_no).

e.g. name(3;2) will return value "9".

 

 
Note: Loop  Index Variable is also considered a Variable and the same rules and functions apply to it.

 

5.3.3 Loop

Navigation:  Tools  > Recipe Flow  >

Loop

Loop Command allows the user to put a number of commands within a loop where their execution will be repeated a defined number of times.

Loop Command Properties Window

The Loop Command has the following properties: 

· Number of Loops field is used to define the number of repetitions of the looped commands. This parameter can be either user entered integer value, result of a math function
or a variable. 

· Loop Index Variable Name is a name of a specific variable, value of which is a number of current loop. Loop Index Variable can be used within the loop for calculations. 

· Use Break Condition option allows to break the loop and continue with the next command outside the loop. If “Break Condition” value is more than zero, the loop will be
broken. 

· Infinite Loop - toggle means the loop will run unlimited number of times. Only one loop will have to be compiled. Infinite Loop does the same action as Run And Clear
Command.

Note: The input command inside the loop can be used with the break condition to break the loop if digital value goes high. 

To place a command inside the Loop, select the command and move it inside the loop using Up/Down Arrow buttons located above the command list. Commands included in the Loop are indented in the Recipe Window.

5.3.4 If

Navigation:  Tools  > Recipe Flow  >

IF

IF is a logical command allowing to execute included commands under certain conditions.
 
IF condition can be written as a mathematical function including variables. I.e. name=1 will check if value of a variable "name" is equal to 1. If it is equal to 1, then commands under TRUE part of IF command will be
executed. If it is equal to anything else but 1, commands under FALSE part of IF command will be executed. After finishing with IF command, recipe continues to following commands.
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To move command under True or False sections, move it UP or DOWN with arrow buttons at the top of the recipe window.
 

 
Commands executed are shown with an indent.

5.3.5 Dialog

Navigation:  Tools  > Recipe Flow  >

Dialog

Dialog command allows to insert messages to the operator during the execution of the recipe.
 
Dialog command can be put at the start, middle or end of the recipe. It can also be combined with an If command to prompt a message if certain condition is met.
 

Dialog Command Properties Window

 

Dialog Command has the following properties:

· Show Cancel Option allows user to cancel the recipe
· Wait For Response pauses recipe until user clicks OK.
 

Formulas and variable names can be used in the message text to show information. E.g. message "Position of axis X is {pos(x)} mm." will display X axis position instead of {pos(x)}.
 

Message returned by the Dialog Command

5.3.6 Pause

Navigation:  Tools  > Recipe Flow  >

Pause

Pause tool adds a pause before next command.
 
Pause (idle) time is entered in [ms] and is usually used to when some external action must be taken or to allow some hardware to settle.

5.3.7 Marking Parameters

Navigation:  Tools  > Recipe Flow  >

Marking Parameters
 

Marking Parameters Command sets marking parameters like speed and laser triggering for the next section of recipe. Section continues until next Marking Parameters command. If different Marking parameters are set
in one of geometry commands, it will override parameters set by Marking Parameters command.
 
Default value of Marking Parameters is -inherited- , which uses the same settings that are used in previous command. If there is no previous command, default parameters are used.
 

Marking parameters w ith -inherited- parameters selected

 
A different parameter set can be selected from a drop down menu. If there are no user saved presets, only "default" preset will be available.
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Marking parameters w ith user preset "Hatching repeat"

selected

 

Changed parameters can be saved on top of existing preset by pressing "Save" or as a new preset by pressing "Save As...".
 
Also current parameters can be set as "Default" by pressing "Make Default".
 
Marking Parameters Command has the following properties:
 

· Color. Draws lines machined with selected Marking Parameters with selected color.

· Device. Select a device that will perform the motion. Usually positioning stages or galvo scanners.

· Repeat. Repeats trajectories a set number of times. If object has depth, it is repeated layer by layer - all repetitions are done for one layer and then next
layer is machined.

· Laser Triggering:

o Laser Triggering Mode sets a mode for laser triggering. Available options are:

§  Position Based (Pulse Pitch), sets laser firing trigger based on current position. Must be supported by the motion hardware. PSO allows
maintaining uniform laser pulse distribution in space during stages acceleration or deceleration.

§  Time Based (Frequency), sets laser firing trigger at a specific frequency. Must be supported by the laser source.

§  Time Based (Frequency Divider), sets laser firing frequency by dividing default laser frequency by integer value (1, 2, 3, etc.). It allows through
every, every second, every third, etc. pulse of the laser.

§  Duty Cycle, sets laser Triggering Frequency and duty cycle (usually used with CO
2 

lasers). Available only when laser control mode Gate is

selected in File>Settings>Laser Control.

§  No Triggering will not trigger laser at all.

o Pulse Pitch (only in Position Based mode) sets the distance between two laser pulses (or laser firing positions to be precise) in mm.

o Pulse Burst (only in Position Based mode) sets how many pulses are shot per laser firing position.

o Triggering Frequency (only in Time Based (Frequency) mode) sets laser triggering frequency in kHz.

o Frequency divider (only in Time Based (Frequency Divider) mode) sets divider for default laser frequency.

· Speed.

o Jump Speed X, Y, Z sets jump (when laser is not firing) motion speed for each axis in mm/s.

o Mark Speed sets combined marking (when laser is firing) motion velocity for all the axes in mm/s. Speed is determined as a total linear speed along

motion trajectory.

· Constant Velocity Between Segments will keep motion when angle between two consequent trajectories is smaller than set in "Decelerate When Angle
More Than". This allows to speed up the process as no deceleration and acceleration occurs.

· Wobble enables galvo scanner wobbling perpendicular to motion path with set Amplitude and Frequency.

 

5.3.8 Transform

Navigation:  Tools  > Recipe Flow  >

Transform

Transform tool modifies following section of recipe (rotates and or translates it).
 
Transform command translates and rotates following recipe, while keeping its integrity and distances between objects.
 

Transform Command has the following properties:

· X, Y offsets (mm) - translates recipe by set value.

· Angle (deg) - rotates recipe by a set value in degrees.

· Rotation Point X , Y (mm) - sets a point around which rotation should occur (as opposed to 0;0 by default).

5.3.9 Find Focus

Navigation:  Tools  > Recipe Flow  >

Find Focus

Find Focus command uses camera or special sensor (e.g. laser height sensor from Keyence) to find position of the surface at a certain point.
 
Camera use with Find Focus command is available only if MV Light or MV Pro module is enabled.
 

Find Focus Command properties

Find Focus Command has the following properties:

· Device selects which device is used to find surface. It can be camera or some dedicated sensor.

· Position sets at which point surface should be looked for. When Z coordinate is used (check box marked) focus will be looked at that height (enter
approximate focus position). 
When Z is disabled, focus will be searched around current Z position.

· There are two modes for focus search:

o Adjust Mode scans Range step by step, stopping after each Z motion by Step Size and capturing focus value. If focus values are decreasing, then

motion direction is changed to
 opposite. Scanning goes on until focus value starts to decrease again or full Range is scanned. This mode is slower, but better for precise focus
finding.

o Scan Range mode scans full range without stopping while constantly measuring focus value. This mode scans whole range faster than Adjust mode,

but accuracy is not as good. When moving constantly focus value is not always refreshed quick enough due to hardware limitations (e.g. fps value for
camera).

o Both mode combines both modes mentioned above. Firstly, Scan Range is done, then Adjust is done from the best focus position found on Scan

Range mode.

· Range sets what range (+/-) should be scanned.
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· Step size sets at what distance interval focus value is measured.

· Export Value To Variable exports measured focus position to a variable with a set name.

· Move Axis To Measured Position moves axis to best found focus position when enabled.
 

 

5.3.10 Z Map

Navigation:  Tools  > Recipe Flow  >

Z Map

Z Map command is used to create surface flatness map and to compensate for it.
 
Z Map compensates for surface flatness in the recipe starting with Z Map Command and finishes at the end of the recipe or at next Z Map Command. Height of commands is compensated in following manner:

· Each object/command is moved in Z direction by the difference between entered Z coordinate in Z Map command and actual measured value. Value for compensation is taken at the center of the command.

· When Stitching command is used, compensation is done for Stitching tiles instead of single objects/commands.

· Between measuring positions Z Map values are extrapolated.
 

 

Z Map Command properties w indow.

 

Z Map Command has the following properties: 

GENERAL Tab:

· Turn Mapping On/Off sets action for the Z Map. Add Z Map command with Turn Mapping Off selected, when you want to stop compensating Z
deviations.

· Operation:

o Create measures Z position at set points and exports data to selected file. This file is then used for compensation.

o Import uses already generated file for Z position values. It is a txt file which can be also created by external software or user.

· Position sets where Z Map should be created (position of center or corner of Z Map depending on reference point set). Difference between entered Z
position and actual measured position is used for compensation.

· Number Of Points X/Y sets how many points is in the measurement matrix in each direction.

· Pitch X/Y sets distance between points in each direction in mm.

· Max Errors Allowed sets how many errors are allowed before error message appears and operation is stopped. Error happens when sensor used for
measuring fails to return a value for set position. In that case position is extrapolated from the neighboring positions.

· Allowed Z Deviation sets how big difference should be to compensate it. E.g. entered value 0.05 compensate Z deviations only larger than 50
micrometers.

 
Z FIND tab sets parameters for measurement of the Z position. Settings are similar with Find Focus command .

 

 
 
 

5.3.11 Export Data

Navigation:  Tools  > Recipe Flow  >

Export Data

Export Data command writes selected data to a text file. It can be used to log positions, value of variables, camera images, etc.
 
Export data command is executed once it comes during the recipe. To log events/statuses multiple times during the recipe add multiple Export Data commands or use them in the loop.
 

Export Data Command Properties Window

 
In Export Data properties select where the text file will be save. Data is saved in tab separated .txt files and can be opened with Notepad or Excel.
 
Select whether existing file with selected name is appended (for multiple lines in the file) or a new one is created.
 
Tip:for best readability, create a new file at the beginning of the recipe and write column names with Text data. Use following Export Data commands to fill
the data in the columns by appending the file.
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Data types that can be exported

 
Data types
Following data types can be exported:

· Text.

Note: Math formulas and variable names can be written within braces {...}. E.g. if we have variables distance=8 and time=4, then Export Data text
"speed={distance/time} mm/s" will return "speed = 2 mm/s" where 2=8/4=distance/time.

· Variable exports value of selected variable.

· Date-Time exports date and time in selected format.

· Save Camera Image saves current view of the camera. See below for more information.

· Position exports position of selected positioning stage or galvo axis.

· Analog/Digital Output/Input exports values of selected analog/digital I/Os.

 

Export Camera Image Command Properties Window

 
When exporting camera image, select:

· Camera by which image should be taken.

· Folder where image file will be saved.

· Image name. {...} can be used to create dynamic image names.

· File format (JPG, PNG, BMP).

· Whether to display or not center cross on the camera view.

5.3.12 Find Corner

Navigation:  Home Tools  > Recipe Flow  >

Find Corner

Find Corner Command uses camera to find the corner of an object.

General Command Properties for Find Corner Command

Find Corner Command has the following properties: 

· Camera - select camera to be used for detection. 

· Angle - define the angle of the corner.

o 90° - use Set Search Area to select 4 points along the corner, 2 points for each edge – for best result choose both points further from the

corner (can be as far as a camera field of view) with the distance between the points similar to the distance from the corner.

o Custom - define the parameters for the corner that has to be identified.

· Edge Extraction Parameters - define Custom Parameters for the Edge Extraction algorithm. 

· Actions - a set of actions done after the corner detection.

o Shift Object to Camera Center - moves the object to the camera center and detects it again for higher accuracy.

o Set Angle Result as – choose what results from the detection are used.

§ Horizontal Edge Angle - the angle of the edge closer to the X axis, result belongs to the interval [-90;90]. 

§ Difference of Set and Found (note that no transformations will be applied during compilation to the following shapes). 

§ Bisector - average of edge angles. 

o Alignment - choose whether to transform the objects following  the alignment command. 

o Set Center as - detected position of the center of the circle will be set as an approximate circle position or as the (0; 0) position. 

o After Error - chose whether to align manually or to continue to the next pattern. 

o After Detection - chose to confirm detection or continue. 

o Use Old Results - will not perform the detection again, but use the results from the previous detection.Detection results are saved in the

Results Tab and variable defined there, they can be reused further in the recipe.
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General Command Properties for Find Corner Command

with Custom Angle selected

Custom Angle Options:

· XYZ - position of the corner vertex.

· Angle of the Corner - user defined angle. 

· Angle of Object’s Bisector – the angle of rotation of the corner. 

· Angle of XY Plane – the angle XY plane makes with the Z-axis. 

· First/Second lookup distance - user defined distance from the corner vertex defined above over which corner detection algorithm will run.

Find Corner Command Custom Edge Extraction

Parameters

Custom Edge Extraction Parameters:

· Blur Strength - changing this parameters can reduce noice. 

5.3.13 Find Edge

Navigation:  Home Tools  > Recipe Flow  >

Find Edge

Find Edge Options are similar to Find Corner Options, please refer to the Find Corner  Section of this Manual for further information. 

5.3.14 Find Large Circle

Navigation:  Tools  > Recipe Flow  >

Find Large Circle

Find Large Circle Command uses the camera to find circular object that does not fit into camera view. If the circle edge is not found, manual edge selection window will pop up. Find Large Circle Options are

similar to Find Corner Options, please refer to the Find Corner  Section of this Manual for further information. 

Find Large Circle Command has the following Properties: 

· XYZ - coordinates for the approximate position of the center. 

· Approximate Radius - estimate for the radius of the circle. 

· Use Old Results option - stops the search if the results are already acquired.

· Shift Edge to Camera Center option - recognized edge of the large circle will be positioned at the center of the camera view to restart search (this is to
minimize the effect of image distortions).

· Angle of the First Point - Angle from the approximate center of the large circle to the first look up point.

· Angle of the Second Point - Angle from the approximate center of the large circle to the second look up point. 

· Angle of the Third Point - Angle from the approximate center of the large circle to the third look up point.

Detection works by locating three segments of a circle at different angles. 
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5.3.15 Image Processing

Navigation:  Tools  > Recipe Flow  >

Image Processing

Image Processing command is used to extract contours and provide statistics of the image. 

Command Properties for Image Processing Command

Image Processing Command has the following Properties: 

Input:

· Source - select the source of an image.

o Image File 

o Camera 

· File - define the path to the image file. It is also possible to use a file explorer to select a desired file. 

Image Processing:

· Method - Select the desired behavior of the Image Processing Command:

o Extract Contours from Image - finds contours in an image file or a camera view. 

o Image Statistics - calculates statistics for the selected image. Values are stored in a variable defined in “Export Values to Variable”. 

By default, output variable name is “info”. 

Exported values: 

§ variable_name.min

§ variable_name.max

§ variable_name.avg

· Edge Extraction Method - Select the desired method for edge extraction: 

o Segmentation.

o Canny 

· Gaussian Blur Sigma - set the standard deviation of the Gaussian Blur effect. 

· Segmentation - toggle Auto or Manual.

· Object is - select Dark or Bright.  

· Morphological Operation - tick box enables morphological operation (set in px) 

· Filter by Size - tick box enables filtering by size (set in px) 

· Clip Edges - tick box enables edge clipping 

· Clip Contours by CAD - dropdown list 

Shape Smoothing:

· Enable Shape Smoothing tick box. 

Output:

· File - define the path to the output file. It is also possible to use a file explorer to select a desired file. 
  

5.3.16 Alignment

Navigation:  Tools  > Recipe Flow  >

Alignment

General Command Properties for Alignment Command

 
General Command Properties:
 

· Alignment Mode:

o Manual - the stage will go the approximate fiducial position, and the exact position will have to be selected manually. For each pattern select

the camera and the position of the pattern to be detected. If the camera is centered on the pattern, click Get Camera Position to read the
coordinates. 

o Simple - the user has to define the area on the camera view, and the matching area is going to be identified as a fiducial. 

o Advanced - specific recognition algorithms are used to find objects in camera view (cross, circle, track, corner, etc.).

· Number of Patterns:

o One - everything is aligned to a single Object.

§ Select Angle - allows user to select angle in manual mode.

o Two - position of two Objects are defined by user and two objects are found. Translation and rotation are then calculated using both objects.

This mode takes more time, but is more accurate, especially when detecting rotation of sample.

o Three - position of three Objects are defined by user and three objects are found.

· Alignment:

o Transform  - the objects after the command will be transformed. 

o None - only the result will be saved in the variable defined in the Results tab.

§ Test - a test can be executed to see whether Objects are found and recipe was aligned correctly.

Pattern 1 Command Properties:

· Camera - select camera which will be used to look for the Object. 

· Position -  enter the coordinates of where the command should look for the object. 

Note: in every other command Position is defined for laser, while in Alignment Command Position is defined for a selected camera. That means that if camera is not coaxial, but parallel to laser beam, the
calibrated offset will be automatically taken into account. 

· Image selection (visible only in Simple Alignment Mode). 

· Match Threshold  - a threshold when a found Object is accepted as correct (visible only in Simple Alignment Mode).

· Parameters - opens a menu of advanced pattern detection parameters. (visible only in Advanced Alignment Mode). 

· Test - runs PATTERN 1 part of the Alignment command only. 

· Results - information on where the Object is found and it's rotation angle. These values can be exported to a set Variable  to use later in the recipe. Vote value shows the comparison results for Simple and
Advanced modes. It is recommended to use a bit lower value in Match Threshold.
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Pattern 2 and Pattern 3 Tabs contain the options for the second and third Object. Available only when Number of Patterns is set to Two or Three in GENERAL Tab. All the options are the same as in PATTERN 1.

 

Pattern 1 Command Properties for Alignment Command in

Manual Alignment Mode

Pattern 1 Command Properties for Alignment Command

in Simple Alignment Mode

Pattern 1 Command Properties for

Alignment Command in Advanced

Alignment Mode

 

Results of Alignment Command

RESULTS Tab shows the final results of the alignment - how much object is translated and rotated.

 

 
 

 

5.3.16.1 Advanced Pattern Detection

Navigation:  Tools  > Recipe Flow  >

Advanced Pattern Detection

In Advanced Alignment Mode special Machine Vision algorithms are used to detect patterns by using a user selected template.
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Templates available for Advanced Pattern Detection: 

· Cross 0 deg 

· Cross 45 deg 

· Cross 45 and 0 deg 

· Think cross

· Grid

· Dashed cross

· Top left grid point

· Top right grid point 

· Bottom left grid point 

· Bottom right grid point 

· Cross 

· Circle 

· Line 

· Corner

· Edge 

· Fit Circle 

· Hough Line 

· Blob

Cross Detection

Cross detection can be used to detect a cross of certain thickness in the image. Cross detection is very accurate (has the sub-pixel option), can detect cross in very noisy images, can detect different crosses in
different backgrounds with the same parameters (depends on parameters and the image). 

The working principle: firstly, cross lines centers are extracted, secondly cross detection is performed. Finally, if the sub-pixel option is selected, the result is adjusted to sub-pixel accuracy. 

Cross detection is based on extracting a line of certain thickness, thus it is necessary to define minimum and maximum thickness of line correctly. These parameters are defined in 'Min line thickness' and 'Max line
thickness' fields in pixel units.  

The thickness of the line in the image can be measured using the measure tool. To measure, right-click on the image and select the 'Measure ' tool from the drop down menu.

Zoom in to the line using the mouse wheel or double click with the left mouse button on the image to enter a full screen mode. Move the mouse to the line edge, right-click on edge, move the mouse to next edge and
right-click on edge. 

A threshold is used for line edge extraction from the input image. A threshold set too high can miss important information (line edges). A threshold set too low can falsely identify irrelevant information (such as noise). 

Next goes cross detection which has two options: 
Symmetric cross - Find cross which is symmetric, lines are perpendicular and intersect 
Perpendicular lines - Perpendicular lines with small-angle tolerance (between lines). The intersection is not necessary - lines will be extended to make intersection. 

Cross pattern identified w ith sub-pixel option

enabled

Angle range to search for rotated cross can be defined using Template angle tolerance parameter. The bigger the angle, the longer the calculation will take. There
is another template for angles of 45 degrees.

The cross-detection part returns the best matching cross that exceeds Minimum score parameter. 
Minimum score parameter can be set in the range [1;100]%. Value of 100.0% denotes perfect cross (two straight perpendicular lines) whereas the value of 70%
denotes that cross must have at least 70% of points that would make the cross shape to accept the candidate.

If Perpendicular lines is selected, the straight lines are extracted using Min pixels in line parameter. Usually Min pixels in line 'should be at least twice smaller
than line length (cross size) in pixels. After lines are extracted, cross detection procedure finds the best line set that makes a cross. 

After cross position is determined it can be adjusted to sub-pixel accuracy if the sub-pixel resolution is needed, check Sub-pixel fitting check box.   
The approximate cross size  in pixels should be defined in Cross size field. If sub-pixel option is enabled, detected cross line edges with sub-pixel accuracy will be
highlighted with light blue colour. 

Thick cross detection

Method is similar to Cross detection  detection, but this method tries to find the most visible cross. Firstly, the most visible horizontal and vertical line points are extracted. Secondly, line fitting is applied (cross center
is an intersection of two lines). Finally, if the sub-pixel option is selected, the result is adjusted to sub-pixel accuracy. This method tolerates non-perpendicular lines. The cross angle formula: angle = (a1 + (a2 - 90))/2,
where a1 is horizontal line angle, a2 is vertical angle. 

Thick dashed cross detection

 Method is the same as Thick cross detection detection, but this method applies an additional step to extract features of hardly visible cross lines. 

Grid detection

Grid detection can be used to detect grid lines-based pattern in the image. Grid detection starts with image segmentation. In this step, grid lines are separated from the background. This can be done automatically if
'Auto segmentation' is checked. If automatic segmentation doesn't provide good segmentation (e.g. contrast between grid and background is low, the image has a lot of noise, the image contains different objects),
manual segmentation can be used. If manual segmentation is used, 'Threshold low' and 'Threshold high' parameters must be set correctly. 

'Erosion size' parameter allows to improve grid lines centre extraction quality and removes small areas(noise). Erosion value must be smaller than half of grid line thickness. If grid line thickness is almost constant, it is
better to set this parameter to 'grid line thickness in pixels/2 - 3', which means to leave only 6-pixel thick line for line centre extraction. 
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Original image contains a lot of noise (bad particles). Image after line extraction w ith Erosion size equal to 0. Bad particles are used in line

extraction.

Image after line extraction w ith Erosion size too large. All information is lost. Image after line extraction w ith Erosion size equal to 15. Bad particles are almost

removed.

After segmentation step grid lines are extracted. Line extraction method extracts all lines that contain more pixels than 'Min pixels in line' parameter. An extracted line might be rejected if a line has an angle that
exceeds 'Template angle tolerance' parameter, the line doesn't fit to grid period or common lines degree. 

It is better to define the minimum and maximum period of the grid. This can be done if 'Autofind grid step' is unchecked. In another case, an automatic period of finding can accept the wrong grid lines period. It can
happen if the grid has only a few lines or grid has many wrong lines that must be rejected. 

If 'Shift object to camera center' is checked, grid corner will be shifted to camera center (if motion stages are available). This also allows for increased recognition accuracy. Usually, the camera view has distortion,
which is smaller in the view center. Using several 'Shift object to camera center' iterations, it is possible to avoid final object recognition in high distortions area. 

The method returns grid corner coordinates ('X', 'Y'), angle('Angle'), period ('ScaleX' and 'ScaleY'). 

Circle detection

Circle detection can be used to detect certain radius circle in the image. The working principle: firstly, edges are extracted using 'Edge threshold' parameter. Secondly, circle detection is performed. 

Circle detection is based on certain radius circle extraction. Thus it is necessary to define minimum and maximum circle radius correctly, or the wrong circle can be extracted. These parameters are defined in 'Min
radius' and 'Min radius' fields in pixel units.
 

The radius of the circle in an image can be measured using a measure tool. To measure, right-click on an image, on the menu strip:
 
Select 'Measure' tool. Zoom in to the most left circle edge using the mouse wheel or double click with the left mouse button on an image to have a full screen image. Move the mouse to the most left circle edge, right-
click on edge, move the mouse to most right circle edge and right-click on edge (divide diameter value by 2 to have radius). 

In 'Min radius' field enter 90% (less or more if radius changes significantly) of measured radius and 110%(less or more if radius changes significantly) of the measured radius in 'Max radius' field. 

A threshold is used for circle edge extraction from an input image. A threshold set too high can miss important information (circle edges). A threshold set too low can falsely identify irrelevant information (such as
noise).

) ‘Edge threshold’ is set to low(a lot of noise is extracted) 'Edge threshold' is set to high (important information is lost).
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'Edge threshold' is set correctly. Two circles edges are extracted.

Circle detected (blue circle indicates detected circle). Min-max radius can be used to extract a

larger or smaller circle.

'Edge chipping tolerance (px)' parameter is used to accept chipped edge point as a valid point when calculating result score. If the distance between edge point and ideal shape edge is lower than this value, the edge
point is accepted as shape point. 

'Minimum score' parameter defines the minimum matching score for the circle to be accepted. Score is calculated by this formula: score = edge_points_detected / max_points, where max_points is '2*PI*Radius'. 

If 'Shift object to camera center' is checked, the circle center will be shifted to the camera center (if motion stages are available). This allows for increased recognition accuracy. Usually, the camera view has distortion
(perspective, barrel), which is smaller in the view center. Using several 'Shift object to camera center' iterations, it is possible to avoid final object recognition in high distortions area. 

The method returns circle center coordinates ('X', 'Y'), circle radius('ScaleX') and detection score('Score'). The score indicates how many pixels apply to detected circle (half of the circle would give ~50% of score). 

Fit circle

Fit circle allows detecting circle center and radius when approximate circle center and radius is known. Circle detection is performed by scanning for circle edges in 16 directions form approximate circle center. Fit
circle method has a significant limitation: camera view center must be inside a circle. If this constraint cannot be met, the circle detection method should be used. 

How to setup:
1. Select camera 
2. If the circle center is not in view center: 
a) Check ‘Advanced’. 
b) Define a search region, which center is approximate circle center. 
3. Right-click on image and in menu select “Measure” tool. Measure the approximate radius of the circle. 
4. Enter the measured radius in “Min radius” and “Max radius”. “Min radius” should be smaller than the measured radius by half of allowed circle
radius deviation. “Max radius” should be larger than the measured radius by half of allowed circle radius deviation. 
5. Enter “Position max deviation” which defines how many pixels circle center can variate compared to defined approximate circle center (view center
will be used if the circle center is not defined). 
6. Click “Run” to test 

Options:

'Edge threshold' – defines the threshold for edge extraction. A threshold set too high can miss edges. A threshold set too low can falsely accept noise in an image as the edge. The purple colour represents the
detected edge.
 
'Minimum score' – if the matching score will be higher than the minimum score, the object will be found. Score is calculated by this formula: score = edge_points_detected / max_points, where max_points is “Scan
width” *16. 
'Min radius (px)' – minimum radius that detected circle can have. 
'Max radius (px)' – maximum radius that detected circle can have. 
'Position max deviation (px)' – maximum circle center shift from the expected circle position. 

'Scan width (px)' – width of one direction scan.

'Pattern size (px)' – averaging pattern size. If the image is very noisy, large pattern size allows to average noisy pixels in the scan line. 
'Edge chipping tolerance (px)' - calculating result score, the parameter is used to accept chipped edge point as a valid point. If the distance between edge point and ideal shape edge is lower than this value, the
edge point is accepted as shape point. 

'Edge transition' – allows using different pixel brightness transitions.

'Edge detection type' – allows choosing which edge to use in line scan. Different results of “First” and “Last” edge detection types (“Dark to bright” edge transition is used): 

Edge detection:

Edge detection can be used to detect edge position and angle in the image. 
The working principle: firstly, edges are extracted using 'Edge threshold' parameter. Secondly, the line fitting is applied. 

The edge detection is based on 1D edge profile extraction. To prevent from noisy pixels or specular dots identifying as edge 'Edge threshold' and 'Pattern size' parameters must be set correctly. 

'Edge threshold' parameter should be chosen high enough to remove irrelevant information (such as noise) and low enough to keep important information (main edges) of the object. 
'Pattern size' parameter can be described as average filter size for the average filter, which is applied to the 1D edge profile. This filter filters small pixel brightness deviations in 1D edge profile. 
'Template angle' parameter defines 1D edge profile scan direction in polar coordinate system. 
'Scan width' defines the number of 1D edge profiles to scan. 

Edge transition can be used to extract only edges that bright pixel brightness transitions in scan direction satisfy a certain condition. 

· 'Any' - Bright to dark and dark to bright pixel brightness transitions will be used for edge detection 

· 'Dark to bright' - Only dark to bright pixel brightness transitions will be used for edge detection 

· 'Bright to dark' - Only bright to dark pixel brightness transitions will be used for edge detection 

Edge detection type: 

· 'Max difference' - Maximum pixel brightness difference in scan line will be used for edge identification. Edge will be identified only if the brightness difference will be larger than the edge threshold. 

· 'First' - First-pixel brightness difference in scan line will be used for edge identification. The edge will be identified only if the brightness difference will be larger than the edge threshold.
 

· 'Last' - Last pixel brightness difference in scan line will be used for edge identification. The edge will be identified only if the brightness difference will be larger than the edge threshold. 

For line fitting 'Min pixels in line' parameter is used, which defines the required minimum of pixels for the line to be approved. 'Min pixels in line' cannot be larger than 'Scan width'. The line which has the largest number
of pixels will be identified as the edge. 

If 'Shift object to camera center' is checked, the line center will be shifted to the camera center (if motion stages are available). This allows for increased recognition accuracy. Usually, the camera view has distortion
(perspective, barrel), which is smaller in the view center. Using several 'Shift object to camera center' iterations, it is possible to avoid final object recognition in high distortions area. 
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The method returns line center coordinates ('X', 'Y'), line angle('Angle') and detection score('Score'). If edge is not found - score is 0, if found - score is 1. 
 

Corner detection:

 Corner detection can be used to detect corner nose position and nose angle. If the corner is rounded and 'Fit arc to corner' is checked, corner detection also finds corner rounding radius. 
 Firstly, the corner angle must be defined in the 'Template angle' field. The angle is defined in a polar coordinate system where the corner nose is pointing at
 Corner angle 0 deg,      Corner angle 90 deg,    Corner angle -90 deg,    Corner angle 45 deg. 

The method is based on edge extraction and line fitting. Firstly, this method tries to extract the first edges in the scan direction. Scanning starts from the background to the corner ('Template angle' is used to know
where is the background). 
Only edges which exceed 'Edge threshold' and are first in 1D scan profile, will be used for line fitting. This method works better when the background is constant or is out of focus. 

After edges are extracted, line fitting is applied. If the corner nose angle is more than 100 degrees, it is suggested to specify approximate corner nose angle in 'Corner nose angle' field, which is visible if 'Advanced'
checkbox is checked. If 'Fit arc to corner' is checked, corner rounding radius range needs to be specified in 'Min radius' and 'Max radius' fields. 

The method returns corner noise coordinates ('X', 'Y'), corner nose orientation ('Angle'), corner nose angle ('ScaleX'), corner rounding radius ('ScaleY') and detection score('Score'). If corner is found - score is 0, if found -
score is 1. 

If 'Fit arc to corner' is checked, corner noise coordinates will be coordinates where the centerline of corner intersects with an arc. 
If 'Fit arc to corner' is not checked, corner noise coordinates will be coordinates where two lines that makes corner intersect.

5.3.17 Wait

Navigation:  Home Tools  > Recipe Flow  >

Wait

Wait Command Pauses the Processing and waits for the user to manually restart it. 

5.3.18 Recipe

Navigation:  Home Tools  > Recipe Flow  >

Recipe

Recipe command allows user to call another recipe in the current one. Geometric transformations can also be defined for the imported recipe. 
 

 

Recipe Command Properties

Recipe Command has the following properties: 

· File field can be used by the user to select a desired file.

· Open button is used to open a selected file in a new Recipe Tab.

· Transform group of parameters is used to translate and rotate the recipe from its original position.

o 'X offset' moves recipe by set distance in mm on X axis.

o 'Y offset' moves recipe by set distance in mm on X axis.

o 'Angle' rotates recipe clockwise direction by set angle in degrees.

o 'Rotation Point X/Y' sets a rotation point for 'Angle' transformation.

 
This command is usually used to call some standard subroutines of the machine e.g. calibration, system startup preparation, etc. or to divide long and complex recipe into
separate parts. E.g. when several different parts need to be manufactured, each part can be added as a separate Recipe Command.

 

5.3.19 View Control

Navigation:  Tools  > Recipe Flow  >

View Control

View Control Command allows disabling hatching display in following part of the recipe. That is sometimes needed when there are a lot of hatching lines and it takes lots of PC resources to display it. View Control affects only preview, but
hatching lines are still executed by motion devices (stages or scanners).
 
 
 
 
 
 

5.3.20 Note

Navigation:  Tools  > Recipe Flow  >

Note

Note Command lets user put some notes in the recipe for future reference.
  

Note Command Properties Window  

 
 
 
 

5.3.21 Cancel Execution

Navigation:  Tools  > Recipe Flow  >

Cancel Execution

Cancel Execution Command interrupts the execution of recipe. 

5.3.22 Run and Clear

Navigation:  Tools  > Recipe Flow  >

Run and Clear

Run and Clear Command clears completed Commands from the view and forces execution of uncompleted Commands in the buffer.
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5.3.23 Settings

Navigation:  Tools  > Recipe Flow  >

Settings 

Laser Offset Command Properties

laser_offset(c) and laser_offset(name;c) – function returns laser offset which can be found in Settings->Laser Control->Laser Offset X;Y;Z. Parameter c
defines coordinate axis: x, y or z. Parameter name defines which laser tool should be used. Laser tool name can be defined by name or index starting at 1.
If laser tool name is not defined, last selected laser tool is used.

E.g
laser_offset(x) – returns laser offset of selected laser for X coordinate (value can be found in Settings->Laser Control (last selected)->Offset X)
laser_offset(2,y) - returns laser offset of second laser tool for Y coordinate (value can be found in Settings->Laser Control (second tab)->Offset Y)

5.3.24 Array

Navigation:  Tools  > Recipe Flow  >

Array 

Array command allows the user to replicate the same object multiple times. 

To start – add a command to the recipe and add all the required geometries inside the Array command.

Array Command has the following Properties:

· X/Y Count is how many columns and rows to produce.

· Step X/Y is the step distance in X and Y directions.

· Offset X/Y is the offset for the first array element.

· X/Y Loop Index Variable Name allows inputting custom variable names for iterations/indexes in X and Y direction.
 

Using Array Command: 

1. Simplest way is to multiply an object in an array. For that just add and object inside the Array command and set the Array properties.

2. Advanced way is to utilize X and Y Index Variables. As can be seen in the example screenshot above, using the variables the user can set different marking or other parameters for each object.

a) Add Variable command for each property to variate it in X or Y direction across the array.

b) In the Variable command:

i. Under the Name input the variable name that would represent the property it will adjust.

ii. Under the Value input a formula that would utilize the iterating index variable. For example, to iterate hatching distance we can set 0,1 * ix. This will iterate hatching distance in X direction multiplying 0,1 by 1,
2, …, n.

c) Now enter this variable name into the parameter it should adjust. In the hatching case, we enter it in object’s hatching tab for spacing property.

d) To see what parameters are being changed for the object we can add a text command above the object and in Text Input add the description with the variable name in {} brackets. {} is needed is this field is
strictly text field. 
In this way we can flexibly test many different parameters quickly. The formula or variable can be entered for any parameter that hast an input field.

5.4 Devices

Navigation:  Tools  >

Devices
Devices section describes the use of tools/commands in the Devices group in Home tab.

 

Devices Tool Group in the Home Tab

Device Commands control the behavior of hardware devices during the execution of the recipe.
 
Device Commands can be called from the Devices, the commands are:

· Output  (controls digital output).

· Serial Port  (controls Serial Port).

· Stitching  (combines galvo scanner and linear stages motion).

· Axis  (moves, homes, enables, disables specific axis).

· Wait For Trigger  (adds a pause in the process until specific digital input is triggered).

· Input - allows the user to read analog or digital input from selected device.

· Camera Control  - allows the user to access camera settings from the Recipe Window.

· External Start.

· RTC Auto Calibration. 

· Laser On/Off  - allows to turn the laser on/off or trigger the laser emission for a specified amount of time.

5.4.1 Output

Navigation:  Tools  > Devices  >

Output

Output Command sets selected digital output on the selected device to low or high value.
 
To add Output Command click on Output in Devices group in Home tab.
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Output Command Window

Check the "Change Value" checkbox to set value for specific output. Click on Change Value to check all the boxes.
 
Set whether the value should be set to high or low.
 
Settings for this command can be saved as a presets for easier use in the future.

5.4.2 Serial Port

Navigation:  Tools  > Devices  >

Serial Port

Serial Port Command send messages to devices through the serial port.
 
To add a serial port command click on Serial Port in Devices group in Home tab.
 

Serial Port Command Properties Window

Select the appropriate serial port number.
 
Set the parameters described in the user's manual of your device.
 
For message parameters please see user's manual of your device.

String message can contain variables and functions inside braces { }. Please look at Text command for more information.

 

5.4.3 Stitching

Navigation:  Tools  > Devices  >

Stitching

Stitching Command combines galvo scanner and linear stages motion.

Stitching Command divides trajectories in the recipe into smaller fields (tiles). Machining within tiles is then performed by using galvo scanners and motion between tiles is performed by using positioning stages.
This allows to perform machining at speeds available only with galvo scanners in the field available only with positioning stages.
To add Stitching Command to the recipe, click on Stitching in Devices Tool group in Home tab.

Stitching Command Properties w ith Grid Type selected

Note: Turn Stitching ON for the Recipe section after the command. If you do not want to use stitching for whole recipe, turn it off by adding Stitching command at
desired place and marking Turn Stitching OFF.

Stitching Command has the following properties:

· Stitching Type:

o Grid - divides all trajectories to rectangular tiles of set size (in Galvo Scanner Field (Tile) Size) and machines tile by tile.

o Object Centering - centers all objects smaller than tile size at the center of galvo scanner. Usually used when great accuracy is needed, and field

distortion is too big to achieve accuracy at the outer areas of the field. Objects larger than set Tile size are divided to Tiles same as in Grid mode.

· Galvo Scanner Field (Tile) Size - sets the size of the tiles into which the trajectories are divided. Set it smaller than your maximum galvo scanner field
size to ensure precision.

· Random Splitting - randomizes the splitting between the tiles in the defined distance to ensure smother joining of the tiles.

· Transform:

o Tiles - with the alignment command the tiles are going to be transformed accordingly.

o Object - with the alignment command the individual objects are going to be transformed accordingly.

· Stage Motion Speed (mm/s) - sets motion speed for X and Y linear positioning stages when moving between tiles.

· Max Cluster Size - chose the size that should not be divided. DMC will tile according to this size. If there are objects in the CAD larger than this size,
DMC will divide this large object according to Galvo Scanner Field (Tile) Size. 

· Trajectories Order:

o Layer by Layer - choose if the process is 2.5D. In other words, the whole 2D layer should be complete before moving to the next layer.

o 3D - if trajectories are 3D.

· Move Z After:

o Single Tile - when object has some depth in Z direction, whole depth is machined for each tile separately. One tile is machined at whole depth and

them next tile is machined.

o Whole Field - when object has some depth in Z direction, depth is achieved for whole object layer by layer. At first all tiles are machined at one Z

position, then Z is moved to next position and again all tiles are machined. 
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Stitching Command Properties w ith Object Centering

Type selected

· Z direction - sets starting point and direction of Z.

· Z Stage Motion Speed (mm/s) - sets motion speed for Z axis.

· Tile sorting:

o None - keeps original order defined in CAD.

o Shortest Jump - tiles are sorted so that the jump to the next tile is shortest.

o Inside to Outside - this sorting is for the trajectories, inside trajectories will be processed before the outside trajectories.

o Snake - will sort the tile to be processed in the order of the snake.

§ Direction - chose axis and direction

§ Snake Width - if distance changes in the selected direction for any of the tiles, DMC will add that tile to the next pass. To widen the pass width,
increase the snake width.

o Rotation First/Last - used when the stitching is on the rotary axis.

· Image Stitching Settings are for the bitmap stitching. This change width/height is to shift tiles if the tile border happens to be on the center of the pixel,
for the pixels not to overlap or to generate a gap.

· Actions before/after tile - the user can select recipe to run before/after each tile.

Additional properties when rotary axes are enabled: 

· Rotary axis: which rotary is used for stitching.

· Rotate around: around which axis this rotary is rotating.

· Radius: rotary axis radius.

· Length is the pattern division step around the rotary axis.

· Rotation center is the offset for the rotation center. If it is left unchecked, the offset is taken from the CAD that is being stitching position.

Additional properties when on fly stitching is selected: 

Note: Motion direction is the axis on fly direction

Note: tile width should be no more than half the scanner field size, height can be full height.

· Width/Height to Retain - is the size of the object to retain in X and Y direction. In the direction of the Fly axis the width to retain should be smaller than
the galvo field size.

Note: The selected width can not be larger than the width of the galvoscanner field. Increasing the width may result in longer recipe running times. If set
value is equal to the width of the galvoscanner field and the Fly Axis is X, the stages will stop on every object of such size if Fly axis is Y, to many columns
(passes) may be generated. 

· Fly axis - the axis used as the on-fly axis.

· Use Park Position - the Command is intended for on-the-fly applications where the laser focus needs to be moved to a safe parking area during an
intermediate motion. This option in some cases can help achieve better processing time result.

5.4.4 Axis

Navigation:  Tools  > Devices  >

Axis
Axis tool is used to add an action for specified axis.
  
Axis tool allows moving, homing, enabling and disabling a specific axis.
 

Axis Command Properties Window

 
The Axis Command has the following properties: 

· Action drop down menu allows the user to specify a desired action.

1. Move action is used to position axis to a specified location. 

2. Home action returns the axis to it's default location. 

3. Enable action activates the selected axis. 

4. Disable action deactivates the selected axis. 

5. Set Acceleration action is used to define the acceleration of the axis in mm/s2.

6. Cancel Motion action is used to stop the motion of the axis when Wait Until Action is Finished option is not enabled. 

· Axis Name drop down menu allows the user to select the axis name from a list of configured axes. 

· Coordinate Type option allows the user to switch between Absolute or Relative Coordinates. 

· Position field can be used to define a location to which the axis will move if Move action is selected.  

· Speed field can be used to specify the speed at which the axis will move to a specified location.  

· Wait Until Action is Finished option allows the user to specify whether the system waits for the action to complete. If Yes is selected, the next command
will be executed only when the previous one is finished. If No is selected, the next command will be executed immediately after the action command is
given for the previous command (e.g. while rotary is still turning to set position).

5.4.5 Wait For Trigger

Navigation:  Tools  > Devices  >

Wait For Trigger

Wait For Trigger tool adds a pause to the recipe until a specific digital input is set to high/low value. 
 
Select a device which inputs will be monitored.
 
Select which inputs will be monitored and on which value recipe should continue.
 
Settings for this command can be saved as a presets for easier use in the future.
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Wait For Trigger Command Properties Window

5.4.6 Input

Navigation:  Tools  > Devices  >

Input

Input – command allows to read analog or digital input from selected device.

Input Command Properties Window

The Input Command has the following properties: 

· Type option allows the user to switch between Digital or Analog input. 

· Device drop down menu allows the user to select a hardware device from which the data should be read via selected input. 

· Port field allows the user to specify a desired port. 

· Variable Name field allows the user to specify the name of a variable which is used to record the data input.

Received input value is saved into a specified variable. Created variable is available right after the Input Command. Digital input sets the value of a variable to 0 or 1. 
Analog input sets the value of a variable in Volts.  

If digital type is selected, during command execution digital value (0 - LOW or 1 - HIGH) will be read from selected device. If analog type is selected, during command execution analog value in volts (-V; +V) will be read
from selected device. Digital and analog value will be set to used defined variable. User defined variable will be available in the recipe after this (Input) command. At compile time, value 0 will be set to user defined
variable.  

5.4.7 Camera Control

Navigation:  Tools  > Devices  >

Camera Control 

Camera Control Command allows the user to access camera settings from the Recipe Window. 

Camera Control Command Properties Window

 

The Camera Control Command has the following properties:

· Camera drop down menu lists all the available cameras in the system. 

· Set Exposure Time option allows the user to define the exposure time. The value can be entered in the Exposure time (ms) field in milliseconds. 

· Set Gain option allows the user to define the Gain of the camera. A numeric value can be entered in the Gain field. 

· Track Camera View toggle is used to keep the Preview Window always centered on the camera view. 

· Move to Camera button switches the view in the Preview Window to the current Camera View. 

· Set Laser to Camera Offset (View Position) option is used to set a laser position to camera position offset for each camera, and each laser separately. 
. 

                  

5.4.8 Attenuator

Navigation:  Tools  > Devices  >

Attenuator

Attenuator Window 
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Attenuator Command Properties Window

Attenuator Command has the following Properties:

Attenuator Command Properties can be found under Devices -> More. 

· Adjust Power mode allows to declare desired power value. The attenuator will be automatically controlled to reach this Target Power (W) value.  

· Set Attenuator in % option allows to declare the desired percentage of the power output in the range from 0% to 100%. 

· Allowed Deviation (W) window can be used to declare the margins for the output power in W. Power will be continuously adjusted until the desired power output (±
Allowed Deviation) is reached. 

· Continue Monitoring option allows to enable continuous power monitoring and adjustment if laser is on throughout the operation and power meter is active. 

· Error Deviation (W) window can be used to declare a maximum error on the power output. If this value is reached recipe execution will be paused. 

· Auto Resume option means the execution of a recipe will resume automatically whenever the output power is again within the desired range after a pause.

· Laser Fire option starts laser emission. This option is not needed when the laser is always on and the power meter can always measure power.

5.4.9 Laser On/Off

Navigation:  Tools  > Devices  >

Laser On/Off

Laser On/Off command – allows to turn the laser on/off or trigger the laser emission for a specified amount of time.

Laser On/Off Command Properties Window

Laser On/Off Command has the following properties: 

· On - option starts the Laser emission. 

· Off - option stops the Laser emission. 

· Time - option starts the Laser emission and continues for a specified amount of time. Time is measured in microseconds. 

 Note: If Laser On Command is immediately followed by the Motion Command, Laser On indicator might be turned off (depends on Motion/Trigger Controller). 

5.5 Positions

Navigation:  Tools  >

Positions

Positions shows current position of the positioning axes.
 

Position Fields in the Home Tab 

Additional information may be displayed on custom versions for specific systems.
 
 

5.6 View

Navigation:  Tools  >

View

View tools controls the preview window.
 

View Tool Group in the Home Tab

Available tools are:
 

·  Fit Screen: zooms to the view of whole recipe. 

·  Reset: returns to default top (X;Y) view of full machining area. 

·  Zoom In: zooms in view in the preview window. 

·  Zoom Out: zooms out view of the preview window. 

·  Measure: measures distance between two points. To measure a distance click on the tool, click on the first point on the preview screen and then on the second point. Result is displayed at the bottom of the
window in status bar. This tool only works in X;Y view. 

·  Show Jumps: this tool sets whether to show or not jump motion trajectories (when laser is not firing). 

·  Saves current Preview Window image. 

· View modes: 

o  Top view displays objects from top. It is the only mode in which drawing can be done by hand.

o  Front view.

o  Right hand view.

o  Left hand view.

o  Back view.

o  Bottom view.
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o  Isometric view.

o Disable/Enable Snapping Toggle. 

o Show Models - shows or hides 3D models in the preview window. 
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6 Control Tab
Navigation:  »No topics above this level«

Control Tools

Control Tools section describes the tools available in the Ribbon Menu Control Tab.

Control Tab

 

Following Tool Groups and Tools are accessible in the Control Tab:

· Process            Cancel button to stop the machining process. 

· Diagnostics      Tools related to observables of the machining process.   

· Galvo               Galvanoscanner related Tools.

· Control             General Control Flow functions. 

· IO                     Input/Output related  settings.

6.1 Process

Navigation:  Control  Tools > Control Tools  >

Process

Process Toggle can be used to stop the current machining process. 
 

Process Toggle in the Control Tab

6.2 Diagnostics

Navigation:  Control  Tools > Control Tools  >

Diagnostics

Diagnostics Tool Group holds tools used for process monitoring. 
 

Diagnostics Tool Group in the Control Tab

Diagnostics Tool Group has the following tools: 

· Chart - allows the user to draw a chart from imported data. 

· Data Monitor - allows the user to monitor certain parameters throughout the machining process.

· Inspect Data - provides information about a selected data point. 

Control Chart Drop-down Window

Chart Drop-down Window has the following items: 

· FIle - path to the data file can be given in this field or file can be selected using a file browser.

· Auto Reload - when this toggle is enabled the file will be automatically reloaded every time configuration is changed. 

· Title Row  - this field holds the index for the row of data category titles in the selected file.

· First Data Row - this field holds the index for the first row of data points in the selected file. 

· Column For X Data - this field holds the index for the column of data to be displayed on X axis of the chart.

· Column For Y Data - this field holds the index for the column of data to be displayed on Y axis chart.

· Save Image - button allows the user to save the chart to a file. 

Data Monitor Drop-down Window

Data Monitor Drop-down Window has the following items: 

· Monitoring  - this toggle enables or disables process monitoring.

· Device Name - drop down list of devices available for monitoring. 

· Measurement period  - this field holds the value of user selected time interval between measurements. 

· Points to show - this field allows the user to select how many data points of the current measurement to display.

· Measured Parameters - a list of toggles for the desirable parameters to be monitored. 

· Color From - allows the user to select color coding from Laser Control Unit or define custom colors for Laser Active and Laser Inactive states.

· Clear data - clears all the data for the current measurement. 

·  Save CSV - saves a CSV file of the current measurement. 
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6.3 Galvo

Navigation:  Control  Tools > Control Tools  >

Galvo

Galvo Tool Group holds tools used for galvo-scanner setup. 
 

Galvo Tool Group in the Control Tab

Galvo Tool Group has the following tools: 

· Galvo Calibration  - allows the user to run Galvo-Scanner Calibration Dialog. 

· Galvo Distortion Correction  - allows the user to run Galvo-Distortion Correction Dialog. 

6.4 Control

Navigation:  Control  Tools > Control Tools  >

Control

 

Control Tool Group in the Control Tab 

Control Tool Group has the following tools: 

· Enable Axes - enables all axes.

· Disable Axes - disables all axes.

· Home - returns all devices and axes to the default position. 

6.5 IO

Navigation:  Control  Tools > Control Tools  >

IO

 

IO Tool in the Control Tab 

IO - Tool opens an Input/Output Interface Drop-down Window.  

Connected Input and Output devices can be identified and monitored here. 

IO Drop-down Window
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7 Camera / Vision Tab
Navigation:  Tools  >

Camera / Vision  

Camera / Vision Controls group contains tools used when working with cameras. 
 

Camera/Vision Tab in the Ribbon Menu 

 

· Adjust View                   Controls Camera view settings.

· Adjust Exposure           Controls Camera exposure. 

· Autofocus                      Automatically finds the best focus position for the camera by moving one of the stages, usually the Z axis. 

· Track View                    Keeps the Preview Window centered on the camera view. 

· Topmost View              Selects the view at the top.

· Visual Inspection          Moves the camera to a specified position for closer inspection.

· To Camera                   Selects the current camera view.   

· To Laser                       Moves the Camera to the current Laser position. 

· Save Image button can be pressed to save a snapshot of the current camera view. 

· Perspective Correction  tool is used to adjust the camera view when camera is at an angle to the surface. 

· Set View Size/Position  tool is used to match the camera view position with coordinate system of stages and/or galvo scanners.

7.1 Selected Camera

Navigation:  Tools  > Camera Controls  >

Selected Camera

Selected camera tool in Camera/Vision tab.
 

Selected Camera Tool Group in the Camera/Vision Tab

In the Selected Camera tool, all configured cameras are shown by configuration order in Settings (Camera 1, Camera 2, etc.) and with their defined names.
 
Selected Camera tool has two functions:

· Clicking on camera button, zooms view of that camera to take full Preview Window.

· Active camera (orange background) indicates which camera is controlled with tools in Controls  and Calibration  tools.

7.2 Adjust Camera View

Navigation:  Tools  > Camera Controls  >

Adjust Camera View

Adjust View tools controls camera view (picture) settings.
 

Adjust View tools for camera view control

 
Available settings depends on the controls allowed by specific camera drivers.
 
Default values are stored in File>Settings>Hardware>Camera X> View

7.3 Autofocus

Navigation:  Tools  > Camera Controls  >

Autofocus

Autofocus tool finds best camera focus by moving positioning stage, usually Z axis.
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Autofocus Window

 
Focus Modes
 
There are two focusing modes:

· Scan Range. This mode scans full range set in Scan Range field by continuously
moving selected axis. Axis is then moved to the best found position. This mode is
usually used to find an approximate focus position.

· Adjust Focus. This mode moves axis by a set step (Step Size parameter) to one
direction. If focus quality (defined by Focus Value parameter) decreases, then scan
is aborted and continued to opposite direction. Scan continues until Focus Value
starts to decrease again or Scan Range limit is reached. Axis is then moved to the
best found focus position. This mode is usually used to find the best focus position.

 
Focus values found during scanning are displayed in the graph on the right of the window.
Vertical axis represents stage position, horizontal axis represents Focus Value. Best
Focus value is the right most one.
 
Settings
 
· Camera parameter, sets which camera will be used for finding focus. Default selection

is camera selected in Selected Camera  tool.

· Axis sets which axis is moved during scanning.

· Approximate position sets the middle of the scanning range. When check box is not
checked, a current position is used. Check box to set a different position.

· Scan Range sets limits for scanning to positive and negative directions. A value '1 mm'
means that axis will be moved from +1 to -1 mm in relation to Approximate position.

· Step Size sets how often focus position is evaluated when scanning. In Adjust Focus
mode, axis is moved in steps of this size as well.

 

7.4 Track View

Navigation:  Tools  > Camera Controls  >

Track View

Track View when enabled, centers camera view in Preview Window .
 

 
In Track View mode view of Selected Camera is centered when axis moves and when zooming as well.

7.5 Perspective Correction

Navigation:  Tools  > Camera Controls  >

Perspective Correction

Perspective correction compensates perspective when camera is looking not at the right angle to the surface.
 

Camera view without perspective correction

 
To compensate, click on the "Perspective Correction" and use corners or orange rectangle to select corners of a square in a camera view. It can be some square object or marking. Use zoom to select corners
accurately.
When square is selected, click apply and view will be recalculated to compensate for perspective.
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Camera view after perspective correction

 

7.6 Camera Calibration

Navigation:  Tools  > Camera Controls  >

Camera Calibration

Calibration tools allows to calibrate camera view to match fabrication trajectories.
 

 
Click Set View Size/Position and then click on camera view and drag it to a desired position and click on camera view corners to set camera view size (to match some fabrication lines). Click Enter to confirm.
 
Iterate between actions to calibrate camera view.
 

Camera view before calibration. Drag and change scale to match camera view with fabrication trajectories.

 

Camera view after calibration.
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8 Edit Tab

Edit Tab
Edit Tools section describes the tools available in the Edit Tab of the Ribbon Menu.
 

Edit Tab in the Ribbon Menu 

Edit Tab has the following Tool Groups available:

· Create 3D.

· Edit . 

· Export .

· Lead In Out.

· Presets . 

8.1 Edit

Navigation:  Edit Tools  >

Edit 

Edit Group Tools are used to edit the CAD objects before processing them. 

Edit Tool Group
 

Edit Group contains the following Tools / Options : 

· Edit. 

· Apply.

· Cancel.

· Delete.

· Group.

· Ungroup.

· Invert Selection.

· Fill Gaps.

· Set Start Point. 

· Point Collection . 

8.1.1 Point Collection

Navigation:  Edit Tools  >

Point Collection

Point Collection Tool allows the user to define multiple points using the mouse. 

Point Collection Drop Down Window

Using the tool: 

1. Press the Add/Remove button in the drop down menu. 

2. Left Click to add a point, Right Click to remove a point. 

3. Press Escape to stop adding points.

X and Y coordinates of the added points are those of the mouse cursor position in the laser coordinate system. The Z coordinate is the current position of the laser focus in the Z axis. 

Create Variable button creates a variable with an array of points.

Update Variable button updates currently selected variable with an array of points.
 
Export to File button is used to export the array of points to the user defined file. Coordinates in the file are separated by a TAB. A new set of coordinates is added to the new line.
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8.2 Export

Navigation:  Edit Tab  >

Export 

Export tools are used to export various objects to a CAD file. 

Export Tool Group in the Edit Tab

 

Export Tool Group contains the following tools: 

· To CAD Object

· To CAD Objects 

· Model To File  - export selected STL objects to STL file. 

8.2.1 To CAD Object

Navigation:  Edit Tools  >

To CAD Object

Apply rotation rotates original drawing and assigns defined rotation angles to zero.

8.2.2 Model To File

Navigation:  Edit Tools  >

Model to File

Model to File Tool allows the user to export  a number of selected shapes to a file. If 3D models are selected, the tool will export selected models to one .stl file. If 2D shapes are selected, selected shapes will be saved in
.dxf, .dwg or .plt file format.

8.3 Presets

Navigation:  Edit Tab  >

Presets 

Presets Tool Group Contains the Preset Library Tool

Presets Tool Group in the Edit Tab
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Preset Library Drop Down Window

To copy parameters to remote folder, select files in
local folder and click “To Remote” button. Green
preset indicates that preset is different (or doesn’t
exist) compared to remote/local preset.
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9 Edit 3D Tab

Edit 3D Tab
Edit 3D Tab contains tools used for editing 3D Objects. 

 

Edit Tab in the Ribbon Menu 

Edit 3D Tab has the following Tool Groups available:

· Edit 3D  - tools used to edit an existing created or imported 3D object. 

· Create 3D  - tools used to create a new 3D object. 

9.1 Edit 3D

Navigation:  Edit Tab  >

Edit 3D  

Edit 3D - tools used to edit an existing created or imported 3D object. 

Edit 3D Tool Group

Following tools are available in Edit 3D Tool Group in the Edit 3D Tab of the Ribbon Menu: 

· Edit Mesh     - edit faces of an imported .stl file.

· Split by X Plane         - splits object into two parts across the X plane.

· Split by Y Plane         - splits object into two parts across the Y plane. 

· Split by Z Plane         - splits object into two parts across the Z plane.

· Split by 3D Plane       - splits object into two parts across the plane positioned in a 3D space. 

· Clip                            - clips the 3D object from 6 sides. 

· Subdivide                  - divides a 3D object into triangles. 

· Projection                  - projects 3D model faces to 2D XY plane (creates a closed contour) and makes CAD command. 
 

· Model To File            - exports the 3D object to file 

Note: to split an object: Left-Click on the face where splitting plane needs to be positioned. Splitting plane can be moved by CTRL+mouse wheel. Press Enter to split the object into two parts. When “Split by 3D
Plane” tool is used, three points need to be defined to indicate a splitting plane.

3D Projection and Projection to 2D commands:

· Projection to 2D command allows to use 3D Projection command’s 3D model 2D projection for projecting 2D shape on 3D model. 

Create New – creates new clipped model. 
Apply – applies clipping to selected model. 
Fill Hole at Cutting option allows to close opened holes with cut operation (when possible)

Tolerate Flipped Faces - Models might have flipped-incorrect faces which can be accepted
Wall Angle (deg) - Projected geometry will be removed from the wall face if wall face angle is more than this value

9.2 Create 3D

Navigation:  Edit Tab  >

Create 3D  

Create 3D - tools used to create a new 3D object. 

Create 3D Tool Group

Extrude – select closed 2D shape and activate tool. Move mouse or enter value directly to define extruded shape thickness. 

Revolve – revolves 2D shape around Y axis and rotates created 3D shape 90 deg around

Create Shape tool - allows the user to create a shape from a drop-down list of predefined shapes.  
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10 Command Properties
Navigation:  Tools  > Geometry  >

Command Properties

Command Properties Window is where the respective settings can be found for a Command, an imported Object or a Device used in the Recipe. 

Note: The selection of Tabs and parameters will vary depending on the selected entry in the recipe.
 

Command Properties Window for a Rectange Object

10.1 Shape

Navigation:  Tools  > Geometry  > Command Settings  >

Shape
Size settings sets the size of the object in milimeters (mm).

 

· File shows the path of currently imported file. Another file can be selected by clicking Browse.

· Size  X,Y,Z shows the size of the imported object in [mm] and allows the user to change the size in each of the coordinates. Original size is
displayed on the right for user's reference.

· Position  X,Y,Z shows the position  of the object in [mm].

o Absolute option allows the user to set the position in absolute coordinates.

o Relative option allows the user to set the  distance to the last position.

o Original option resets the position to the initial coordinates stored in the CAD file.

o Reference Point allows the user to select which part of object (center, top, bottom, left, right, corners) is referenced by setting the position.

· Transform  allows the user to:

o Flip the object along a selected axis.

o Rotate the object in [deg] around a selected axis. 

For drawn objects, e.g. Rectangle, X and Y size can be changed independently, aspect ratio can be changed.
 
For imported objects e.g. DXF, STL files, aspect ratio is locked. After changing size in one dimension others are recalculated accordingly.
 
Original size of the imported object is shown on the right.

10.1.1 Object Position

Navigation:  Tools  > Geometry  > Command Settings  >

Position

Each object that is drawn or imported has its position settings. Position settings are displayed in Command window (default position on the right side of the screen).
 
Depending on the object, position settings can be displayed with or without reference point:

DXF Command Properties SHAPE Tab

When Reference Point option is available, Position represents the position of the selected reference point of the object e.g. center or top left corner.
When Reference Point option is not available, Position represents position of the Start or End of the object, e.g. Start and End coordinates of the Line.
 
Absolute, Relative and Original Position of the object
 
Position of the object can be described in Absolute and Relative coordinates or Original coordinates of the imported object (DXF, STL files).
 
Absolute coordinates describes object's position in relation to 0;0 of your coordinate system.
Relative coordinates describes object's position in relation to:

· the reference point of the last object that was done before it (Relative R.)

· or to the last laser position (Relative L.)

Original coordinates position object in the coordinates set in the CAD (DXF, STL, Gerber) file. It is convenient, when multiple objects are imported, that
needs to be position precisely in relation to one another, e.g. Gerber file with trace marks and NC drill file with via holes in PCB.
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Line Command Properties Position Settings

 Z Position
 
Since most of the trajectories are machined at the same height, Z position is by default disabled.

· When disabled (check box is not checked, field is inactive), Z position of the object is at the current Z position.

· When enabled (check box is checked, field is editable), Z position of the object works the same way as X and Y positions.

Please see an example of absolute and relative coordinates of a line below.
 
First Line command is set to start at absolute 0;0;0 and end at absolute 1;1;0 coordinates (X;Y;Z).
Second Line command is set to start at 0;0;0 and end at 1;2;0. See how second line changes depending on Absolute and Relative Start and End position settings. Also open Lines.rcp in Samples folder to try the
changes.
 
1.Start Position Absolute, End Position Absolute

 
2.  Start Position Relative, End Position Absolute

 
3. Start Position Relative, End Position Relative
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10.1.2 Transform

Navigation:  Tools  > Geometry  > Command Settings  >

Transform

Transform settings allows user to flip and rotate objects.
 

 
Flip option inverts object's coordinates along selected axis (see pictures below).
 
Rotate option, rotates object around selected axis and selected reference point.
 
Important: all transformations are done in following order:

1. Position and Size of the object.

2. Flip X, Flip Y, Flip Z.

3. Rotate around X axis, rotate around Y axis, rotate around Z axis.

When some of the parameters are changed, all the parameters are recalculated again in the order above.
 

Samples:
 
1. Original DXF file

 
2. Object Flipped along X axis
 

 
2. Object Flipped along Y axis
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2. Object Flipped along X and along Y axes
 

 
2. Object Flipped along X axis and rotated -30 degrees
 

10.2 Hatching

Navigation:  Tools  > Geometry  > Command Settings  >

Hatching
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Hatching is a tool to fill the volume of an object. Hatching is available for following commands: 

· Circle 

· Rectangle 

· Import CAD

Hatching tool can be accessed by clicking on a HATCHING in Circle/Rectangle/Import CAD Tool Parameters menu.

 
Check Enable Hatching to use Hatching tool.
 
Settings for Hatching tool
 

· Leave Original Contour allows user to leave or delete original contour of the object. If it is unchecked motion trajectories will be generated only for
hatching.

· Make Contour First / Make Hatching First sets whether contour or hatching lines are machined first (when hatching is enabled).

· Hatching Type allows to select different hatching modes used for different applications/effects.

· Spacing sets a distance [mm] between hatches (lines, dots, contours).

· Hatching angle rotates [deg] hatching pattern.

· Offset to Contour generates a new contour with a set distance to original one. Original contour is deleted. Offset values can be positive or negative.

· Offset to Hatching sets an offset distance so hatching is started not at the contour but by some offset. This is usually used for beam spot
compensation. Note, that if Offset to Contour is used, Offset to Hatching is calculated from the new offset contour. 

· Marking parameters selects a different Marking  parameters for hatching.

· Border Thickness option allows to make a hatched border of defined width. When the value is zero, full contour will be filled. 

· Use Hatching Centering option positions the hatching lines at the center of the shape.

· Lines hatches object with lines.

· Grid hatches object with a grid of perpendicular lines.

· Dots fills object with dots distributed at even distances in X and Y direction.

· Hexagon Dots fills object with dots distributed in Hexagon pattern.

· Contour hatches object by creating contours with a specified offset.

· Custom Pattern hatches a user defined pattern.

Custom Pattern 

Click “Select Pattern” button and select shape in the view to use as hatching pattern. 
Vertical spacing can be constant or varying. When varying option is selected, “Y Position Variable” and “Column Index” needs to be defined. Defined variable
needs to have data array with column where Y positions (reference is individual shape center) are defined. Data array can be imported from csv file. Data array
must have only numbers – header in file is not supported. 

Hatching pattern should be disabled or removed after selecting it. Hatching remembers this pattern, and if pattern needs to be modified, it should be reselected
after modifying it.

“Center Pattern” checkbox allows to align selected pattern center to individual shape center. If pattern needs to be shifted, move pattern from 0;0 to required
offset, reselect pattern and uncheck “Center Pattern” checkbox. 

Interlacing - Range: [1, N]. Distributes hatching sequence in multiple passes by skipping every X lines in single pass. "

Custom Pattern selected for Hatching
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Hatched Custom Pattern

10.3 Marking

Navigation:  Tools  > Geometry  > Command Settings  >

Marking

Marking sets the Marking Parameters for a specific command.
 
Default value of Marking Parameters is -inherited- , which uses the same settings that are used in previous command. If there is no previous command, default parameters are used.
 

Marking parameters w ith -inherited- parameters selected

 
A different parameter set can be selected from a drop down menu. If there are no user saved presets, only "default" preset will be available.
 

Marking Command Properties

 
Changed parameters can be saved on top of existing preset by pressing "Save" or as a new preset by pressing "Save As...".
 
Also current parameters can be set as "Default" by pressing "Make Default".
 
Settings
 
· Color. Draws lines machined with selected Marking Parameters with selected color.

· Device. Select a device that will perform the motion. Usually positioning stages or galvo scanners. Some further options are available only for certain
galvo or positioning stages controllers.

· Repeat. Repeats trajectories a set number of times. If object has depth, it is repeated layer by layer - all repetitions are done for one layer and then
next layer is machined.

· Laser Triggering:

o Laser Triggering Mode sets a mode for laser triggering. Available options are:

§ Position Based (Pulse Pitch), sets laser firing trigger based on current position. Must be supported by the motion hardware. PSO allows
maintaining uniform laser pulse distribution in space during stages acceleration or deceleration.

§ Time Based (Frequency), sets laser firing trigger at a specific frequency. Must be supported by the laser source.

§ Time Based (Frequency Divider), sets laser firing frequency by dividing default laser frequency by integer value (1, 2, 3, etc.). It allows through
every, every second, every third, etc. pulse of the laser.

§ Duty Cycle, sets laser Triggering Frequency and duty cycle (usually used with CO
2 

lasers). Available only when laser control mode Gate is

selected in File>Settings>Laser Control.

§ No Triggering will not trigger laser at all.

o Pulse Pitch (only in Position Based mode) sets the distance between two laser pulses (or laser firing positions to be precise) in mm.

o Pulse Burst (only in Position Based mode) sets how many pulses are shot per laser firing position.

o Triggering Frequency (only in Time Based (Frequency) mode) sets laser triggering frequency in kHz.

o Frequency divider (only in Time Based (Frequency Divider) mode) sets divider for default laser frequency.

· Speed

o Jump Speed X, Y, Z sets jump (when laser is not firing) motion speed for each axis in mm/s.

o Mark Speed sets combined marking (when laser is firing) motion velocity for all the axes in mm/s. Speed is determined as a total linear speed

along motion trajectory.

· Constant Velocity Between Segments will keep motion when angle between two consequent trajectories is smaller than set in "Decelerate When
Angle More Than". This allows to speed up the process as no deceleration and acceleration occurs.

· Constant Marking Velocity Mode adds margins for acceleration and deceleration at the start and end of trajectory. Motion will be executed through
whole trajectory including acceleration/deceleration margins without stopping. This is used to mark whole trajectory at a constant speed, usually to
get uniform laser pulse density on whole trajectory. Manual mode allows setting length of the margins manually while Auto mode calculates length
automatically based on you acceleration values in the File>Settings>Stages.

· Wobble enables galvo scanner wobbling perpendicular to motion path with set Amplitude and Frequency.
 

21 22 73



79Command Properties

© 2021  

 

10.4 Thickness

Navigation:  Tools  > Geometry  > Command Settings  >

Thickness

THICKNESS Properties allow the user to set parameters controlling the thickness (depth in Z axis) thus allowing to either cut or engrave an object.

Thickness Command has the following properties: 

· Enable Engraving/Cutting enables motion in the Z axis for the object.

· Thickness sets the thickness of the object in mm. 

· Layer Thickness sets the distance between two layers of the object. Number of layers is calculated by dividing the value in Thickness by the value in
Layer Thickness. Note that if there is no remainder after division, last layer is at Thickness - Layer Thickness. 

· Change Hatching Angle allows the user to change the hatching angle for each consecutive layer by a set degree. If  Cross Hatching is used, the
angle is changed for all of the lines. 

· Hatching Offset allows the user to shift hatching pattern in X and Y direction at different layers.

· Return Z to Start resets the Z axis to the starting Z position for the object. This is used, when several objects are starting at the same Z position and Z
position is not enabled or relative. With this parameter disabled, several layers of engraving with different parameters can be easily added. 

· Show All Layers controls whether all or just the first layer is displayed. Sometimes, when working with a lot of complex objects, disabling this
parameter might save computer resources. 

· Show Hatching controls whether hatching is shown for all but first layer. To disable Hatching display for all layers including first, use View Command
in the Recipe Flow Tool Group.

10.5 Parameter Locking

Navigation:  Tools  > Geometry  > Command Settings  >

Parameter Locking

Parameter Locking feature locks Process Presets and Marking Presets. When Preset is locked, none of parameters are visible and can not be changed. To lock Presets successfully save Preset settings after Locking (or Unlocking).
 

Preset Parameters Lock

Set Password for Lock

  

Preset Lock is ON
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11 Configuration and Set Up
Navigation:  »No topics above this level«

Configuration and Set Up

You can configure DMC software by following File > Settings.
 
Follow these steps to configure DMC software for work with your laser system (if a certain device is not included in your system, skip that step and continue with the next one):

1. Positioning stages. If your system has motorized positioning stages, configure appropriate controllers  and stage  parameters.

    a. Go to File > Settings > 'Your controller' to enable and configure the motion controller. There are several motion controllers available: ACS , Aerotech , Newport , Polaris.
      
        Note: in some cases different controllers can  be used to control different stages.
        Note: for Demo license, skip this step and go to 1. b.

    b. Once your controllers are enabled and configured, go to File > Settings > Stages to configure your positioning stages .

2. Galvo Scanners. If your system has galvanometric scanners , configure them at File > Settings > Galvo Scanners. 

        Note: in some cases, galvo scanners are controlled by the same controller as positioning stages. In this case they should be configured as a secondary positioning stage setup.

3. Laser Triggering. Configure your laser triggering  parameters by following File > Settings > Laser Control.

4. Camera. Configure the cameras  used for sample / work area by following File > Settings > Camera 1/2/3.

5. Click OK at the bottom right corner to save the settings and exit Settings window.

6. Click Connect To Hardware at the Home Tab of the Ribbon menu.

Click Connect To Hardware in the Ribbon menu.

7. DMC will try to connect to all the configured hardware devices. Sometimes connection to some devices might take a while and the software may look like it is not responding. Usually it takes no more than 10
seconds. If it takes more than a minute and the software is still not responding, contact support . If DMC is unable to connect to some active device an error message will pop up informing which device is not
available. Some devices allow only one connection at a time - check if the device is not linked to any other software. For device specific troubleshooting follow the device manufacturers instructions. If that does not help
contact support .

8. If connection is successful try moving positioning stages by using a Joystick .

9. Test laser firing settings by clicking Laser Fire button on the Joystick  and by marking something.

10. Test galvo scanners, by marking e.g. letter F using 'Text' command in the Ribbon Menu.

11. When all of the main devices are working properly continue by enabling system specific devices like power meters, other sensors, special electronics etc.

11.1 IO Tools

Navigation:  Configuration and Set Up  >

IO Tools

Can Run Recipe If State Is - if the digital input state doesn’t match the user defined allowed state, recipe will not run.

11.2 Motion Controllers

Navigation:  Configuration and Set Up  >

Motion Controllers

Select motion controller that you would like to configure to work with DMC.
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11.2.1 ACS

Navigation:  Configuration and Set Up  > Motion Controllers  >

ACS

To set up ACS motion controller for use in DMC go to File>Settings>ACS. Controller should be already configured through MMI studio before configuring it in DMC.
 

ACS controller settings

1. To enable ACS controller use in DMC mark 'Enabled' check box at the top of the Settings window.

2. Set controller name. This is to identify controllers if more than one controller is used in the setup.To add additional ACS controller click 'Add New Controller' button at the bottom of the window. 

3. Select connection type: Network / Serial / PCI Bus / Simulator. Most common is Network connection. 

4. Set connection settings. IP address for Nework connection or COM port and Baud Rate for serial connection. To get that information, right click on the controller in MMI Studio and click Properties.

5. Select network Connection type: Point to Point / Network depending on whether your controller is connected directly or via a network router/switch.

6. Laser Control. Steps 6-8 are needed only if laser has to be triggered via ACS controller.

7. Select Laser Triggering Type as 'Digital Output' or 'PD and Digital Output'.

Digital Output triggering will create a gate signal for a set 'Laser Control Pin'. A high signal will be set to that output whenever a marking trajectory is executed.
Note: this option allows only time based laser triggering i.e. laser firing will not be dependand on stage motion velocity/speed.
To check if laser triggering works correctly check selected pin with oscillator or voltmeter when marking or check Digital I/O window in MMI studio.

PD and Digital Output laser triggering type in addition to gate signal as above creates a TTL signal using one of the drives that can  configured as a Pulse Direct (PD) axis. For information whether your drive can be configured for it and how
to do that consult your ACS manual.

8. Select an index of axis which is configured as PD axis in 'PD Index'. Additionally set which digital output pin will be used for gate signal.

Default ACSPL+ Position Based Triggering Configuration code.

9. Laser triggering for ACS controller must be set in the Configuration, Start and End sections. In most cases Configuration section is enough. You may use a default code for standard ACS configuration.

10. Set additional actions by entering ACSPL+ code if needed in 'Additional Actions' section. It may be used for automatic homing on connection, stepper stages closed loop monitoring and other actions.

11. Set what ACS controller buffers will be used by DMC in 'Limit Controller Buffer Usage' section. DMC should have at least 3 buffers available.
 
Troubleshooting
 
No connection to controller.
Check if controller is available in ACS MMI studio. Check if its IP maches IP address set in DMC.Try changing between Point to Point and Network types of Connections.
 

81 81



83Configuration and Set Up

© 2021  

11.2.2 Aerotech

Navigation:  Configuration and Set Up  > Motion Controllers  >

Aerotech

To set up Aerotech A3200 motion controller for use in DMC go to File>Settings>Aerotech. Controller should be already configured through tools provided by Aerotech before configuring it in DMC.
 

Aerotech A3200 controller settings

Aerotech Controller setup: 

1. To enable Aerotech controller check enabled check box at the top.

2. Aerotech A3200 firmware version is detected automatically.

3. Select number of PSO channels that will be used. It depends on the controller configuration.

4. Set PSO Axis Letter. It determines which axis controls PSO signal (e.g. 'PSOCONTROL X ON' in Aerocode).

5. Select whether to use default PSO output location. If not a default configuration is used, set output pin and output mode.

6. If laser is triggered through digital output pin instead of PSO output, select 'Use Digital Output For Laser Control'.

Select which axis and pin to use.
Select if laser should be triggered with high or low signal.
Set delays before and after marking. They are usually needed to compensate for shutter opening/closing time.

Aerotech custom control code

Custom AeroBASIC code can be added to software generated and executed control code. Four different files can be used to insert code into different locations:

Use AeroCodeAtTheBegining.txt file to add custom code into start of generated code.

Use AeroCodeAtTheEnd.txt file to add custom code at the end of generated code.

Use AeroCodeBeforeLaserOn.txt file to add custom code before laser triggering code.

Use AeroCodeAfterLaserOff.txt file to add custom code after laser triggering off code.

Files needs to be located in parent folder of .exe file. 

Aerotech notes: 

· PSO WINDOW option for acceleration/deceleration phase with A3200 controller available for lines.

· Dashed line support for A3200.

·  PSO WINDOW ARRAY is used to control firing during continuous marking velocity

11.2.3 Newport XPS

Navigation:  Configuration and Set Up  > Motion Controllers  >

Newport XPS

To set up Newport XPS/XPS-RL motion controller for use in DMC go to File>Settings>Newport XPS. Controller should be already configured through tools provided by Newport before configuring it in DMC.
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Newport XPS and XPS-RL controller settings

 
1. To enable Newport XPS/XPS-RL motion controller for fork in DMC mark 'Enabled' check box at the top.

2. Select which controller XPS or XPS-RL is used.

3. Set controller IP address and User Name and Password.

4. 'Use Default TCP/IP Communication Timeout' controls duration of communication timeout. Sometimes due to delays in the network connection Network Communication Timeout errors appears frequently though
controller is still working. For such cases you can
 disable this check box and set timeout duration manually (even up to several hours if needed).

5. 'Detect Settings' button is available for certain modifications of controller. When available, clicking it will contact controller to search for axis configuration. If found, axis travel distances, speed and acceleration settings
will be automatically set in the 'Stages' settings.

6. Set what group name is used for XY axes.

7. Set maximum discontinuity angle allowed. The parameter itself is available in the MARKING parameters. When two joining lines are at an angle bigger than the set angle, motion will be split to two parts and stages will
decelerate at the joint.

8. Disable or enable XY Line Arc Verification function in the controller. It is recommended to keep it enabled, though in some cases it is known to provide errors where it still works well, therefore disabling it allows to
bypass such errors.

9. Select which port is used for laser triggering and whether signal should be high or low.

10. Set delays before and after marking. Usually they are used to compensate for shutter opening/closing duration.

11.3 Positioning Stages

Navigation:  Configuration and Set Up  >

Positioning Stages

To configure positioning stages, firstly, enable and configure appropriate motion controller.
 
Positioning stages can be configured in File>Settings>Hardware>Positioning Stages. Actual configurable fields of the stages might differ depending on motion controller you use.
 

Positioning Stages Settings Window

 
You can enable axis by checking Enable box.

Generic settings for stages:
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· Controller selects which controller is used to control the stage. Different stages can be controlled by different controllers, though X and Y stages should have the same controller type. 

· Stage Name sets a name to be used in the software. Name does not need to correspond to one set in controller. 

· Acceleration Mode allows to select whether stage acceleration cure will be linear (even acceleration) or sinusoidal (slower start and end with steeper increase of acceleration in the middle). 

· Max acceleration for jump sets maximum acceleration for jump (no laser firing) mode in mm/s2 

· Default acceleration for jump sets a default jump acceleration value which is used for jump motions. 

· Max speed sets maximum available speed for that axis in mm/s. If higher value is entered in the recipe an error message will be provided. 

· Default jump speed sets a default value in recipes for jump speed in mm/s. 

· Min/Max position sets the limits of the axis travel. both positions can be positive, negative or zero. Value is set in mm. 

· Invert axis direction inverts coordinate direction comparing to hardware settings. E.g. if in controller settings coordinate increases when moving from left to right, with Invert direction checked it will increase moving
right to left. 

· Home offset sets a new Home position. After homing axes go to a location defined by offset and sets it as 0;0 coordinates. 

· Home Position (mm) sets a value for position that is achieved after homing. E.g. homing is done by touching negative limit switch, then Home offset moves stage to a certain position and Home position states that
that position is -100. 

· Relative motion before homing moves stages a defined distance before homing action. 

· Home priority sets homing priority for each axis. Axes will be homed starting with priority no. 1 and then moving down the list. In some configurations different homing priorities are necessary to avoid crashes, e.g.
lowering Z axis to not damage focusing lens. 

· Auto disable axes on exit – disables all the axes if closing software while still connected to the hardware.

11.4 Galvo Scanners

Navigation:  Configuration and Set Up  >

Galvo Scanners

Galvo Scanner can be configured in File>Settings>Hardware>Galvo Scanner.
 

 
To enable gavo scanners check Enable at the top of settings window.
 
Settings
 
· Controller Type: set the controller you are using  (RTC4/5, Raylase or virtual controller). 

· RTC Card Number: select number of RTC card if more than one is used. 

· Laser Mode: set the laser mode.

· Field Settings:

o SWAP XY Axes, changes X axis to Y and vice versa.

o Invert X, Y direction inverts axis direction (changes positive values to negative and vice versa)

o bits/mm sets your field size / resolution.

o Calculate allows you to calculate correct bits/mm value. Mark a square with DMC and measure its actual size.

Enter the size of square that is in Rectangle command and actual measured size.

o Size X,Y,  sets field size in X and Y directions.

o Offset X,Y, offsets 0;0 position by set values.

o Scale X,Y,

o Field Rotation, rotates field around 0;0 position.

· Select Lens Correction File sets a lens correction file to use for this scanner.

· 'Move to 0;0;0 Position At The Start Of The Recipe' moves galvo scanners to zero position before doing anything
else. It helps to avoid confusions when using relative coordinates.

· 'Move to Predefined Position After Marking' moves galvo scanners to a set position after galvo scanners are finished
with their actions (e.g. end of recipe, motion of Z stage, actions by other devices). X Y Z fields define that position.

           Galvo Scanner Settings Window
· Default Speed:

o Default Mark Speed sets a default motion speed when laser is on.

o Default Jump Speed sets default motion speed when laser is off.

· Delays. See Controller card manual for galvo scanner delay information.

   

11.4.1 Galvo Scanner Calibration

Navigation:  Configuration and Set Up  >

Galvo Scanners

81

81



86 DMC User Manual 

© 2021  

Galvo Calibration tool is in the Control tab in the Ribbon.

NOTE: for this tool to work stages (XYZ*) and camera must be configured. (Z stage is optional)
 
 There are two main steps in the calibration procedure. Step one is to mark the grid and step two is to find the location of the marking to generate a calibration fi le.

NOTE: before doing the calibration make sure that in galvo scanner settings axes are not swapped or inverted.

NOTE: before doing the first iteration of the calibration it is advisable to set at least approximate bits/mm value in the galvo scanner settings. To do this, mark a known size square and measure the actual marking, then enter
those values in the bits/mm calculator in the galvo scanner settings and set this value for bits/mm.

NOTE: before doing the calibration make sure that the settings for the galvo scanner in DMC Settings are set correctly. Especially field size, bits/mm and the calibration fi le. Calibration fi le (can be 1to1) must be selected to
generate a new calibration fi le.

Galvo Scanner Calibration Window

For the first step, set the center location of the marked grid. Grid size will be according to the galvo scanner field size setting in DMC Settings.

Select number of points in the grid, a camera that is going to be used for the point detection and marking pattern.

Also, select marking parameters for the pattern. If no marking parameters are saved, add any shape in the recipe and select appropriate parameters to get good quality markings. Save those
marking parameters by clicking on ‘Save As…’. 

Marking Command Properties

After completing this step, select those marking parameters in the Galvo Calibration tool. To see the tool again, click the ‘Galvo Calibration’ button again, all the

previous settings will not be reset.

Now mark the grid – click ‘Mark’ button.

After the grid is marked, select the Detection Mode:

- Manual – each cross must be selected manually.

- Automatic Simple – select an area on the view in DMC and the tool will search for it.

- Automatic – click Setup to set detection parameters. The principle is the same as when using Alignment command. Please refer to the manual ‘Home tab-

>Recipe Flow->Alignment’.

Also select the correct galvo scanner orientation. In the marking, next to one of the corners there will be a triangle marked and it will be pointing to some

direction. Please choose the setting corresponding to the real situation:
 

Galvo Scanner Orientation Dropdown Menu

After selecting the orientation setting, click ‘Find’. Stages will go to the appropriate points, according to the rotation, and depending on the detection mode,

point location will be recorded.

The detection data is displayed in the table on the right.

Click ‘Inspect’ for the stages to move to the selected point to see how well the detection was performed.

Click ‘Manual Detect’ or ‘Auto Detect’ to redetect the points that were detected incorrectly.

Define the ‘Error Margin’ to the acceptable value, and the larger values will be marked red for easy visual identification.

After correctly identifying all points, click ‘Apply’. Correction file will be generated.

Please select the new correction file in the settings and click OK or apply. Depending on the need, calibration operation can be performed several times to

achieve better accuracy.
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Marking Correction File Selection Field 

11.4.2 Galvo Distortion Correction

Navigation:  Configuration and Set Up  >

Galvo Distortion Correction

The user must mark a grid on a sample and scan this sample with good quality flatbed scanner. Then using this tool, it is possible to generate a calibration file for the scanner.

NOTE: made to generate correction files for the ScanLab RTC card, for other controllers, please contact us separately.
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Bad points can be deleted by going into “Edit” mode. Click “Edit”, delete bad points, click “Apply”. “Delete Unconnected” button can be used to

delete bad points automatically if green crosses are connected to only good red crosses. 

Click ‘Correct Angle & Center’ to shift detected center point to 0;0 and rotate crosses to align red center crosses with horizontal green crosses.

Angle detection options can be selected in the Parameters section. If you only want to correct the center, then use ‘Correct Center’ button.

If some crosses are missing, ‘Fill Gaps’ button can be used.

“Export” button allows exporting crosses to a text file.

If a user has coordinates in the text file, the ‘Import Coordinates’ button can be used instead of an image.

Click the ‘Create’ button to create a correction file. 

NOTE: the accuracy of the calibration depends on the scan DPI and quality of an image.

NOTE: image must be good quality and high contrast to extract all the point automatically. Also, only the points and no additional artefacts must be present. An example of an image:
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Must be done before creating a calibration file:

In the Settings-> Galvo Scanner: 

- Set/confirm galvo size that you used to mark.

- Set/confirm bits/mm value used to mark.

- Set/confirm correction file that was used to mark.

Calibration tool can be found in the Control tab. Here is how to use it.

First set the values in the Parameters section:

- Set distance between crosses in “Step Size”.

- Set how many crosses you have in row and column.

After Parameters are set, click “Import From Image” and select image. Green crosses represent where crosses are expected to be, and red crosses are extracted from an image. If you do not see the crosses, parameters need to

be adjusted.

- When an image is imported, DPI is automatically read to DPI field. Check if DPI is correct.

- If too many points are missing, reduce the threshold to 10 or smaller. 

- “Apply” button applies changes (try to connect red crosses with green). This button needs to be used if you change parameters (step size, columns, …) 

Use ‘Show Point Connections’, ‘Show Points’ and ‘Show Distortion Error’ for different visualization of the result in the View Screen.

NOTE: successful extraction looks like this:
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11.5 Camera

Navigation:  Configuration and Set Up  >

Camera

Cameras are configured under File > Settings > Hardware > Camera 1(2,3)
 

Camera configuration settings General parameters.

 
GENERAL Settings configuration:

1. Check Enable check box.

2. Select camera device from drop-down menu. If your camera is not found, check if it is not used by some other software. DMC supports all cameras with DirectShow drivers and cameras from IDS (uEye), Basler,
Mightex manufacturers.

3. Enter camera name, that will be seen in the commands and Ribbon menu.

4. Select whether to see a cross in the view center.

5. Click Connect to connect to camera.
 
Calibration Settings configuration:

1. Check camera view, and mark Flip and Rotate checkboxes to adjust camera view to match your coordinate system.

2. If distance from camera center to laser is known enter it in Camera to Laser Offset.

3. If View Size (mm per pixel) parameters are known enter them as well.

4. If Camera to Laser Offset and View Size parameters are not known, follow calibration procedure .

5. It is possible to set a value for Delay after Motion in ms. 

81
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Camera configuration settings Calibration parameters.

 
Go to View tab to set camera view default parameters. They can be changed in the Ribbon menu, but on DMC start, default settings set here are restored. Settings available in this menu is defined by camera
manufacturer.
 

Camera configuration settings View parameters

 
 

11.6 Laser Control

Navigation:  Configuration and Set Up  >

Laser Control

Laser triggering and in some cases laser power and rep rate control is configured in File -> Settings -> Laser Control
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Laser Control settings

 
Steps to configure laser triggering control:

1. Select Laser Firing Control Device. Depending on whether you want to trigger laser from galvo scanner controller or positioning stages controller, select an according device. If you are using both devices for motion
control, it is advisable to select galvo scanner as triggering device. 

2. Connect your laser to the triggering device according to your laser and triggering device manuals. 

3. Select Triggering Control Mode supported by your laser source. Triggering mode should be described in your laser operator's manual.

· Edge mode, triggers laser at the rise of high signal only.

· Gate mode triggers while high signal is ON (all pulses during high signal goes through).

4. In case of Edge triggering mode, enter edge pulse width. Different devices need a different time to react to signal change. The value should be described in laser operation manual. 

5. Enter a Fundamental Rep Rate at which laser source is working. It is a repetition rate set in the laser source itself. In some cases, it might be automatically updated by DMC if a connection to laser is established.
Make sure this value is up to date, because it is used for triggering frequency calculations. 

6. Set Min and Max Repetition Rates. Laser sources have an upper repetition rate value and usually a minimum repetition rate value. They should be described in your laser's operation manual. These values are only
used to limit what repetition rate value DMC user can ask for.

 
Laser triggering.
 
Laser can be triggered at a specific frequency using several modes.

1. Edge Mode.

a. Frequency Divider. Frequency Divider must be an integer value, which defines what part of pulses are allowed to go through. I.e. Frequency Divider = 1 will trigger laser at Fundamental Laser Rep Rate by
impulses of Edge Pulse Width, Frequency Divider = 2 will trigger laser at a 1/2 of Fundamental Laser Rep Rate, skipping every second pulse (see picture below) and so on.

b. Frequency. Frequency triggers laser at a user specified frequency regardless of Fundamental Laser Frequency.

c. Position Based Triggering (available only with triggering device supporting this function). This mode triggers laser source whenever pulse is needed depending on motion position. Triggering frequency usually
varies when accelerating and decelerating and is constant at constant velocity.

2. Gate Mode

a. Frequency Divider. Frequency Divider must be an integer value, which defines what part of pulses are allowed to go through. With Frequency Divider = 1 a constant gate signal (high) will be sent. At Frequency
divider = 2 gate signals sequence will be generated at a Fundamental Repetition Rate, where half of time signal is high and half - low. At Frequency Divider = 3, signal will be 1/3 time high and 2/3 low and so on.

b. Frequency. At Frequency mode, a sequence of gate pulses will be generated at specified frequency where signal is half of time high and half of time low.

c. Position Based Triggering works the same as in Edge Mode.
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Laser triggering pulses in various triggering modes.

 
Laser power control with analog output.
 
Some lasers support laser power control with analog input. This function can be configured in DMC File>Settings>Laser Control to be later used in Marking Parameters
 
To use this feature:

1. Enable "Use Analog/Digital Power Control" in File>Settings>Laser Control.

2. Select Device on which is the analog output you would like to use.

3. Select the Analog Port if more than one port is available. If only one port is available, leave value 0.

4. Set Minimum and Maximum voltage limits. Please consult your laser manual and analog output device values to set correct limits. Wrong limits might damage your devices.

5. Now "Output Power (Voltage) will appear in MARKING section of commands.
 
Instead of using voltage to describe power, a voltage - power or voltage - pulse energy correlation table might be uploaded. To do that:

1. Enable "Use Correlation Table" at File>Settings>Laser Control

2. Import correlation table. Correlation table must be csv or txt file where first column represents voltage value and second - power/pulse energy.

3. Set the name for your parameter, depending on what is controlled Power or Pulse Energy. Enter units in ().

4. Select Interpolation Type to select how a value between two entries in table is selected. It can be calculated using linear or spline interpolation or simply a closest value can be set.

5. Now instead of Output Power (Voltage) parameter you will have a parameter with a set name and units. Its value limits are calculated according to imported table.
 
Laser power control with digital outputs.
 
Some lasers support power control via 8bit digital output. You can set it up in DMC File>Settings>Laser Control to be later used in Marking Parameters
 
To use this feature

1. Enable "Use Analog/Digital Power Control" in File>Settings>Laser Control.

2. Select IO Device on which is the digital outputs you would like to use.

3. Select the Start Port and End Port which will be used. 8 consequent ports are needed, e.g. 0-7 ports.

4. If Power Latch is required by the laser, enable it and select which device and which digital output port is used for power latch.

5. Now "Output Power (%) will appear in MARKING section of commands.
 
Using multiple beam paths / lasers.
 
In some machine configurations, more than one laser source or beam path might be used. To set it up in DMC:

1. Click Add in File>Settings>Laser Control.

2. New tab will appear at the top of Laser Control settings window.

3. Click on the second tab (named Laser 2 by default) and set up triggering and if needed power control parameters.

4. Check "Show Advanced Settings" at the bottom of Laser Control settings window.

5. Set a Name for this laser source. Also, you can select a different color for its representation (beam spot position when laser is firing/not firing and its working zone limits).

6. Set offsets for the beam spot of this laser source comparing to Laser 1.

7. Select if this beam path goes through galvo scanner head or not.
 
If beam paths are different and offsets between them are set up, you can see both working zones in DMC Preview window.
In the Ribbon menu Home tab, View group, select More and Show All Working Zones. Now all zones are displayed in their respective colors. When this option is deselected, only the working zone mutual for both beam
paths is shown.
 

Some of lasers support pulse width control via digital input. Software allows to have pulse width control from marking parameters. This feature can be enabled in Settings->Laser Control->Laser Pulse Width /
Waveform Control. 
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Select which digital output device is used to control pulse width. A range of bits can be defined in Start Port and End Port fields. Reverse Bit Sequence changes
order of bits from Start->End to End->Start. Control Text field can be used to set custom name for pulse width control parameter (e.g. to Waveform). First table
column contains numbers that user can enter in marking parameters. If user enters value that does not exist, nearest value will be used. Row index of entered
value will define bit sequence. Second and third column allows to define min and max frequency for a defined pulse width. If field is empty, checking whether
triggering frequency is in range is not performed. Example: user enters 31ns pulse width. Nearest value is 30ns which is at row 2 (starting at 0). Binary 2 is 0000
0010. We use last 5 bits (0 to 4) 0000 0010. If reverse bit sequence is checked, our digital output will be reversed to 0000 1000. Remaining 3 bits will be not
changed.

11.7 Power Meter

Navigation:  Configuration and Set Up  >

Power Meter Setup

Power Meter Window

Power Meter setup for continuous power monitoring: 

1. Tick the Enabled check box under Settings -> Power Meter.

2. Change the model to Analog Input.

3. Choose the name for your device.

Power monitoring via TCP/IP links:

1. Tick the Enabled check box under Settings -> General -> Remote control.

2. Change model to Remote Control in Power Meter Settings. 

3. Press "Connect to Hardware" and use Telnet for power monitoring. Power can be adjusted via the text command "SETPOWER value" where value is the desired power in W. 

Attenuator setup: 

Rotary axis can be used to adjust the power output of your laser system. 

 
Stages Window

1. Tick the Enabled check box for the Rotary Axis under Settings -> Stages.

2. Put in values for Axis Group, Positioner Name, Min/Max Range.  

3. Tick the Enabled check box under Settings -> Attenuator. 

4. Set the Controller Field to Rotary Axis. 

5. Select the desired Power Meter. 

6. The configured attenuator can be selected under Settings -> Laser Control if needed.  
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12 How To..?
Navigation:  »No topics above this level«

How To..?

This section of the manual is a step by step guide for some of the functions in DMC software.
 

12.1 Main Principles

Navigation:  »No topics above this level«

Main Principles

Recipe creation in DMC is both: feature rich and simple at the same time.
 
For simple recipes, such as common marking tasks, you can either import CAD file or draw objects by hand with simple geometrical tools  like circle, line, arc, rectangle. Each tool when used becomes a command in
Recipe window . For better precision you can set parameters such as position and size in Command  window.
 
For more advanced tasks recipe may be created in a high level logical programming way with Recipe Flow  commands. You can import CAD files or add geometrical objects, set parameters for each. You can also
easily repeat the path by adding cycle command. For more flexibility and automation Variables can be used for values of the parameters, that can be changed during the flow of the recipe.
 

Add Recipe Flow commands to create complex and flexible recipes

 
All the commands in the recipe are executed in the order top to down.
 
Some of commands act as a parent commands and have child commands belonging to them (e.g. Cycle is a parent command and all commands included in the cycle are child commands to Cycle). Parent command
has a triangle symbol to it, which allows to expand or subtract view of child commands. Child commands are also indented to right. There might be several layers of Parent - Child relations, with one child command being
parent command for others.

Motion code generation

DMC controls motion devices by generating motion code or control them via control libraries. Multiple commands might be joined into single motion control file/list which should be executed faster (usually in real-time)

by motion controller. 

Commands that divide motion control file: 3D Printing, Dialog, Pause, ZMap, Export Data, Camera commands (Find Corner, Find Edge, Alignment, Camera Stitching, …), Wait, Recipe, View Control, Joystick, Output,

Serial Port, Stitching, Axis, Object 3D, 4D Wrapping, Shape, 3D Projection, Laser On/Off and other commands that control various devices.

Commands that do not divide motion file: Line, Arc, Circle, Rectangle, Text, Polyline, Gerber, Point, Spiral, Ellipse, Barcode, Spline, JumpTo, Variable, Loop, If, Transform, Note

Marking parameters command or marking parameters in geometry command can divide motion control file if: different laser is selected, motion device changes, another device needs to be controlled.

12.2 Quick Access Toolbar

Navigation:  How  To  > 

Quick Access Toolbar 

To add a Tool to the Quick Access Toolbar Right-Click the tool and select "Add to Quick Access Toolbar" from the drop down menu. Tool can be accessed via keyboard short cuts Alt + 1 through Alt + 9. 

Tool Drop Down Menu

Quick Access Toolbar 

12.3 Aligment Command Setup

Navigation:  How  To  > 

Alignment Command Setup 

Alignment tool uses camera view to align all  motion paths of the recipe to the sample. It is usually used to position machining trajectories on a specific position on the sample.
 
Before using Alignment tool make sure, that:

1. Machine Vision (MV) module is installed and licensed.

2. Camera is set up. See more about camera setup here .
 
To insert Alignment click on Alignment button in Recipe Flow group in Home tab in the Ribbon (visible when MV module is installed).
 
Insert Alignment command in the specific place in the recipe. Recipe part before the alignment will  not be aligned.
 
The basic sequence of actions for Alignment command is following: 

1. User defines the position where command should look for the 'Object' (specific mark or view to which everything is aligned). X, Y, Z coordinates are entered. 

2. Object is defined (see Alignment Modes). 

3. Camera view goes to the position defined by user in step. 

4. Alignment command finds Object automatically or user defines it manually. X, Y coordinates and rotation angle is found. 

5. All  the following recipe is transformed by:

· Translating it in X and Y coordinates by the difference between acquired object position (in step 4) and user defined position (in step 1). 

· Rotating it around the Object center (found in step 4) by angle (found in step 4).

6. Following recipe commands are executed.
 
There are three Alignment Modes:

1. Simple. A camera view is selected by operator or loaded from image fi le. Alignment command looks for that image in a specified field. 

2. Manual. Operator manually selects position and angle. 
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3. Advanced. Specific recognition algorithms are used to find objects in camera view (cross, circle, track, corner, etc.).

12.4 Remote Control

Navigation:  »No topics above this level«

Remote Control

DMC can be controlled in remote control mode using TCP/IP interface. To use remote control, enable in the File>Settings>General.
 
DMC Remote Control Module (RCM) enables a master control of DMC application. Using this functionality DMC can be controlled from other software or PC via TCP/IP interface. RCM allows loading recipe files, loading
CAD files into the recipe, changing variables defined in the recipe and running recipes. For full functionality see the list of available commands.
To use DMC RCM an appropriate DMC license must be used (either as license file or USB dongle key). When DMC RCM is licensed a Remote Control section appears in DMC Settings.

Enable remote control in File>Settings>Remote Control and set port.

For remote control to be used DMC must be running either in a default or a background mode. Modes are set in File>Settings>General. Also it can be started in background mode adding “-bg” parameter to it in command

line or exe file shortcut.

Background mode starts DMC without a graphical user interface to save PC resources.

List of commands used in DMC RCM

Command Description Parameters Example

LOAD Loads selected recipe File location and name Message:
load “C:\Recipes\mark 123.rcp
Return:
OK load “C:\Recipes\mark 123.rcp”
Error: Unable to import ‘C:\Recipes\mark 123.rcp’ file. File
does not exist.

UNLOAD Unload recipe Recipe name or recipe
location

Message: 
unload “C:\Recipes\mark 123.rcp”
Return: 
OK unload ‘C:\Recipes\mark 123.rcp’
Error: Recipe ‘C:\Recipes\mark 123.rcp’ is not found.

UNLOADALL Unload all recipes Message: 
unloadall
Return:
OK unloadall

ACTIVATE Activate one of loaded recipes Recipe name or recipe
file name

Message: 
activate “C:\Recipes\mark 123.rcp”
Return: 
OK activate ‘C:\Recipes\mark 123.rcp’
Error: Recipe ‘C:\Recipes\mark 123.rcp’ is not found.

GETACTIVE Get file name of active recipe Message: 
getactive
Return: 
‘C:\Recipes\mark 123.rcp’

COMPILE Compiles current recipe.
‘OK compile’ informs that command is accepted. Check status
with STATUS command to see if compiling was successful.

- Message:
compile
Return:
OK compile

STATUS Returns status of the DMC - Message:
status
Return:
DISCONNECTED
CONNECTING ERROR
CONNECTED
COMPILING
COMPILING DONE
COMPILLING ERROR
RUNNING
PAUSE
RUNNING DONE
RUNNING ERROR
HOMING
HOMING DONE
JOYSTICK ACTION
JOYSTICK ACTION RUNNING
JOYSTICK ACTION DONE

CONNECT Connects to hardware. - Message:
connect
Return:
OK Connect
Error: Unable to connect to ‘Device’.

DISCONNECT Disconnects from hardware. - Message:
disconnect
Return:
OK disconnect

RUN Runs current recipe.
‘OK run’ informs that command is accepted. Check status with
status command to see if there are no running errors.

- Message:
run
Return:
OK run
Error: Unable to run recipe. Not connected to hardware.

PAUSE Pauses running recipe.
‘OK pause’ informs that command is accepted. Pause will be
executed only in places it is safe to resume machining (after jump
motion, after machining slice, etc.).
Check status with status command to see if running is paused.

- Message:
pause
Return:
OK pause

CONTINUE Continues paused recipe. - Message:
continue
Return:
OK continue
Error: Unable to continue recipe. Recipe is not running.

CANCEL Cancels running recipe. - Message:
cancel
Return:
OK cancel

SETVAR Sets value of selected variable. Variable name
Value (formula or
number value)

Message:
setvar speed 30.5 [sets variable speed to value 30.5]
setvar label “text” [sets variable label to value “text”]
Return:
OK setvar speed 30.5
Error: Variable ‘spe’ not found. 

GETVAR Gets value of selected variable Variable name Message:
getvar speed
Return:
speed 30.5
Error: Variable ‘spe’ not found.

SETGVAR Sets value of selected global variable. If global variable does not
exist, it will be created

Variable name
Value – text or number
value

Message:
setgvar speed 30.5 [sets variable speed to value 30.5]
setgvar label “text” [sets variable label to value “text”]
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Return:
OK setgvar speed 30.5

GETGVAR Gets value of selected global variable Variable name Message:
getgvar speed
Return:
speed 30.5
Error: Variable ‘spe’ is not found.

GETVARS Gets all exported variables (access in other recipes) and values
from active recipe

Return format:
Variable name \t variable value \n
Message:
getvars
Return:
speed\t123\npower\t10

GETPOS Gets position of selected axis name Axis name:
x,y,z,gx,gy,gz, axis
name defined in
Settings->Stages-
>Stage Name

Message:
getpos y
Return:
y 10.1234

MARKING Selects MARKING parameter preset for first Marking Parameters
command in the recipe.

Name or MARKING
parameters preset

Message:
marking steel_cut
Return:
OK marking steel_cut
Error: Preset ‘ste_cut’ not found.

HOME Homes selected axis Axis name
If no parameters are
added, all axes will be
homed.

Message:
home
home X
Return:
OK home
OK home X

MOVE Moves selected axis to a set position Axis name in DMC
Position

Message:
move x 10
Return:
Error: Axis ‘Theta’ not found.

LASERON Starts laser triggering, based on current laser control settings.
Similar to clicking on LASER button in Joystick.

- Message:
laseron
Return:
OK laseron
Error: Controller doesn't support FireContinuous function.

LASEROFF Stops laser triggering. - Message:
laseroff
Return:
OK laseroff

ESTIMATE Estimates recipe time. While estimation is in progress, “in
progress” message is returned. When recipe estimation is
complete and “estimate” is called, estimated time will be returned.

Message:
Estimate
Return:
OK Estimate: in progress…
OK Estimate:224h 36min 50s

CLOSE Closes software. - Message:
close
Return:
OK close

TRIGGER Sends a trigger to Wait command to continue recipe Message:
trigger
Return:
OK trigger

VIEW Controls view FITSCREEN
RESET

Message:
view fitscreen
view reset
Return:
OK view fitscreen
OK view reset

 

Usage Example

For an example of use, we create a recipe, which marks a drawing from DXF file and a text label under it. Outgoing messages are in green and incoming in yellow colors.

1. Hardware settings must be setup correctly before using DMC in remote mode. It is best to test configuration settings and new recipes in standard DMC mode. 

2. A recipe for specific type of jobs has to be created. In this case, recipe contains variables for settings, cad file location and text. Save the recipe to a known location, in this case C:\recipes\LogoText.rcp . Sample
recipe can now be used to put any logo file and any text on any position on the sample.

Sample recipe used for remote control

3. Enable remote control and set port to use for communication with DMC in File>Settings>General ‘Remote Control’. If same PC is used, default IP address is localhost (127.0.0.1) Default port is 23. 

4. Establish remote connection to DMC. In this example a simple communication software (PuTTY) is used. Settings for communication in this case is Connection type: Telnet, IP address: 127.0.0.1, Port 23. After
establishing communication DMC will provide a message with its name and version, e.g. DMC 1.2.50 RCM 

5. Check software status with STATUS command. 
status 
DISCONNECTED

6. Connect to hardware and check status, to confirm that connection is done. 

connect
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OK connect
status
CONNECTED 

7. Load recipe to be used. 

load “C:\recipes\logotext.rcp”
OK load “C:\recipes\logotext.rcp” 

8. All the variables in the recipe are set to their default (as saved by user) values. Use setvar commands to change values of variables. In this case variable is also used to define file location of the logo file. Variable logo
contains text written in “”. And file location in CAD Object command is set to {logo}. 

setvar label “Hello World!”
OK setvar label "Hello World!"
setvar logo "C:\models\DXF\Logo.dxf"
OK setvar logo "C:\models\DXF\Logo.dxf"
setvar lsize 5
OK setvar lsize 5
setvar tsize 1
OK setvar tsize 1
setvar hd 0.01
OK setvar hd 0.01
setvar positionx 0
OK setvar positionx 0
setvar positiony 0
OK setvar positiony 0 

9. Select preset for Marking Parameters command using MARKING command. If no preset is selected a preset saved in the recipe will be used. Individual parameters may be also controlled by creating variables for
them in the recipe. 

marking steel15
OK marking steel15

10. Compile recipe to make sure everything is alright. Check the status to see if no compiling errors appeared.

compile
OK compile
status
COMPILING DONE

11. Run the recipe using RUN command. Check status to see if recipe is running or finished.

run
OK run
status
RUNNING
status
RUNNING
status
RUNNING DONE

12. Load next recipe, change variables or close the software using CLOSE command.

12.5 Camera Alignment

Navigation:  How  To..?  >

Camera Alignment

In this section we are describing an Alignment procedure with camera, using Machine Vision (MV) module in DMC.
 
To understand the Alignment principles and procedure, please read through the following sections:
1.Coaxial and off-axis cameras in DMC
2.Camera view in Preview window
3.Manual alignment by dragging objects
4.One point Manual alignment
5.One point Simple alignment
6.Two points alignment
 
To use cameras in DMC software a MV module should be installed. Steps 1-3 can be done with MV Lite and MV Pro, steps 4-6 require MV Pro module. MV Lite module can be upgraded to MV Pro.
 
Coaxial and off-axis camera view.
 
1.Firstly, connect camera(s) to DMC and configure them in the File>Settings. For more information on it check Camera configuration  in this manual.
2.Calibrate your cameras. For more information check Camera calibration  in this manual.
 

Calibrated camera view

 
Camera can be of two types:
·Coaxial camera is a camera that shares focusing optics with a laser beam, usually the same microscopic objective lens or F-Theta lens when using galvo scanners.  Using camera to look through galvo scanners
requires a special adapter to compensate distortion by F-Theta lens. Coaxial camera displays current laser position in the center of its field.
Note, that even a camera using coaxial scheme, might be a little off and center of camera view might not match the laser spot precisely. That might happen due to some missalignment in the optical path. While that is
not critical, it is easier and more intuitive when camera and laser are aligned as good as possible.
·Off-axis camera is a camera that does not look through the same focusing optics used by laser beam. Usually it is used to avoid looking through the galvo scanners, to have a bigger field of view or when several
optical paths are used for the laser on the system.
In the off-axis case, camera is set up with a known offset to laser beam spot. This offset is found precisely during Camera calibration procedure . The offset is used for Joystick Camera to Laser and Laser to Camera
actions and for FindFocus and Alignment commands as well. All the positions that are given for the camera in the Alignment, FindFocus has to be provided in the laser coordinate system and no offsets needs to be
calculated by the user.
 
When several cameras are connected, they can be at any combination, one being coaxial, one off-axis or two off-axis or even two coaxial cameras, even though that is unlikely.
 
Camera view in the Preview window.
 
Camera view is displayed in the preview window at its calibrated position. For Camera calibration procedure  check the manual.
 
When camera is calibrated, its position matches machining trajectories on the screen. So machining trajectories that are displayed over the camera, will be machined on the sample at the place they are seen.
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Off-axis camera view matches machining trajectories

 
Use Track View function and Joystick to see where machining trajectories will be placed on the sample.
 
When several cameras are connected, they are all shown on the Preview window. When cameras are looking at the same spot (i.e. a wide view camera and a microscopic camera) the view of a camera with higher
number in Settings is displayed on top (Camera 2 is displayed on top of Camera 1 view). So configure cameras starting with the one having the biggest field of view.
 
View between cameras can be changed with the buttons in the Ribbon menu Camera/Vision tab. A selected camera is also used by default when using Autofocus tool.
 
Manual alignment by dragging objects.
 
A simplest way to align machining trajectories on the sample is to drag them in Preview window with a mouse until they are in a wanted position on the camera view. It can be precisely adjusted using Position  and
Transform  parameters in the Command window  for each object. Compile the recipe to make sure that all the objects are in the wanted positions.
 
One point Manual alignment with Alignment command.
 
For Alignment command special objects called fiducials are used. In DMC a fiducial can be any object visible on the sample: some corner, cross, edge, etc.
 
The basic principle of using Alignment is this:
1. User defines where fiducial should be (original position).
2.Alignment command looks for fiducial in the original position.
3.Real position of fiducial is acquired (it is usually a little different than position set in step 1) and difference between is calculated as well as rotation of fiducial.
4.The following recipe is transformed accordingly. Objects are translated by the difference of set and real positions of fiducials and rotated by fiducial rotated angle.
5.When two fiducials are used, transformation is calculated from both of them.
 

Schematic view of sample (blue) placed on machine. Red and green arrows represents machine coordinate system.

There are white fiducial crosses on top right and bottom left corners, those fiducials w ill be used as alignment

patterns.

 

Machining trajectories (black) that should be laser-scribed on the white pattern existing on the wafer. Red cross

represents fiducial described for Alignment command.
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Sample is rotated and displaced (i.e. taken away and put back in the machine)

 

There is translation difference between original fiducial position (red cross) and real fiducial position

found by Alignment command (red dashed cross) and rotational difference (angle between red

dashed cross and black lines).

 

System automatically or manually finds a set fiducial.
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Machining trajectories are transformed to match the displacement of the fiducial.

 
For one point Manual alignment insert Alignment command in the recipe before the commands you want to align. Click on Alignment in the Ribbon menu Home tab Process Flow group.
 
1.Go to PATTERN 1 tab and set position for the first fiducial. If you don't know where fiducial should be, use joystick to move to a position on the sample, align camera view center with fiducial or move mouse pointer
over it and use the respective coordinates displayed in Status bar .
2.Click Run to start the Recipe.
3.When Alignment command is executed, camera will be driven over the set position and a pop up window will appear. Click Select to select center of your fiducial and click right mouse button, select rotation of the
fiducial and click again. If the fiducial is not visible in the camera view, use Joystick to move camera view to find the fiducial.
 
Note: you can also use Relative position for following commands to machine at the position the fiducial is found.
 
One point Simple alignment using Alignment command.
 
In Simple mode of Alignment fiducial is a user set image (usually a picture made with a system camera). After creating the picture, no further user interference is needed.
 
1. Go to PATTERN 1 tab and set position for the first fiducial.
2. Move with Joystick so that fiducial would be visible in the camera field.
3. Click Set Image and mark an area on the camera view. Selected area is then a fiducial which should be found. If camera view has many details(i.e. uneven surface with scratches) use Adjust View to adjust camera
view. Use a configuration where your fiducial is seen with best contrast and as few as possible other details are visible. That will help when looking for fiducials in different locations on the sample or on different samples.
4. When Alignment command is executed, camera is driven to a set position and camera view is compared with set image. If part of camera view matches set image fiducial is found.
There is a Match Threshold parameter in the PATTERN tab, which regulates how similar set image should be to camera view.
 

 
User can select action in case fiducial is not found or after it is found. That can be done in GENERAL tab of Alignment command.
 
Two points alignment using Alignment command.
 
Two points aligment is similar to a single point alignment. The only difference is that PATTERN 2 tab is active, where parameters for second fiducial should be set. After finding both fiducials, transformation of the recipe
is calculated according to both of them. Two poitns alignment is mostly used when small rotation errors needs to be compensated.
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Two alignment fiducials are described in Alignment command for two point alignment.

 
 

Machining trajectories are transformed to match fiducial displacement.

 
 

12.6 DLP printing

Navigation:  How  To..?  >

DLP Printing

Setting up DLP printing on your system: 

1. Disable all Galvo Scanners as well as the X and Y axes on the Positioning Stages under  File > Settings > Hardware. 

2. Under File > Settings > DLP Printing click the Check box to enable DLP Printing. 

3. Enter the physical dimensions of your DLP Screen in Size X and Size Y fields.  

4. Enter the resolution of your DLP screen in the Resolution field. 

5. Select the Hologram Generator in the Hologram Generator field. 

· None – no hologram generation is performed, slices are sent to the DLP Screen as plain black and white images.

· CGH – holograms are generated using Gerchberg – Saxton algorithm before getting sent to the DLP screen.

6. CGH Iterations – generate and refine each hologram over a number of iterations defined in this field.

7. Images per Exposure – the number of holograms generated and displayed with each exposure of a slice.

8. Scale Down Factor – parameter defining the resolution scaling of the original slice image when generating a hologram. 
 For example, the default factor of 4 would scale down the slice image resolution to 320 x 256 pixels.

9. Generate Square Hologram toggle – when enabled, the source image is extended to form a square for
hologram generation (e.g. a scaled down 320x256 pixel image becomes 320x320 pixel image). 
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Disable X, Y Positioning Stages in Settings

Disable Galvo Scanners in Settings

Enable DLP Printing in Settings

The original image isn’t distorted in any other way. When this option is unchecked however the generated hologram looks different. So disabling the Square Hologram should be tested on the actual hardware and the
results should be reported to the software developers. 

Note: increasing the Iteration Count and Images per Exposure increases the time needed to generate the hologram, increasing the Scale Down Factor decreases it. Simple benchmarks of one hologram generation time
are provided in the table below (Intel Core i7-6700HQ CPU @ 2.6GHz, 16 GB RAM):

Hologram Resolution (Scale Factor)
1280x1024 (1) 640x512 (2) 320x256 (4)

Iterations
70s 17s 5.9s
29s 8s 3s
15s 4s 1.4s

DLP Printing on your system: 

1. Add to the recipe a 3D Printing command and import a CAD object (make sure the CAD fits into DPL field size).

2. Under 3D printing Command Properties in the Settings tab define the slicing distance and in the Marking tab the user can control two parameters: Exposure Time and Pixel Dimming.

a. Exposure Time controls hologram exposure time.

b. With pixel diming only every second pixel is lit up.

3. Click Connect to Hardware (make sure you have a hardware connected over HDMI or VGA, can be a standard screen).
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a. Before connecting to hardware and if you are using two screens, make sure that DMC is running on screen 1, as DLP projections will be displayed on screen 2.

4. Click run and the projections will be displayed through the hardware or the screen.

12.7 DLP Image

Navigation:  How  To..?  >

DLP Image

Using DPL Image: 

1. Select the command DLP Image from Home ribbon, Devices group.

2. If the DLP image is to be displayed during the process:

a. Add DLP Image command above other commands

b. In Command Properties

i. Select an Image file

ii. Check Display Image box

iii. Make sure Wait for Exposure checkbox is off

c. After clicking run, the image will be displayed on the second screen while the process is running.

3. If the DLP image is to be displayed after the process:

a. Add DLP Image command after all the other commands

b. In Command Properties

i. Select and Image file

ii. Check Display Image box

iii. Make sure Wait for Exposure checkbox is on

iv. Set the exposure time in seconds

c. After clicking Run, the process will be executed as defined in the recipe and after the image will be displayed for the specified time.

12.8 XL SCAN

Navigation:  How  To..?  >

XL SCAN

XL SCAN Tab in Settings

Setting up XL SCAN: 

· Enable and configure ACS Motion Controller .

· Enable XL SCAN in XL SCAN tab in the Settings

· Load the XML file 

· Configure the XML file according to the hardware setup with
syncAXIS Configurator (below). To start the Configurator,
click on Edit Configuration File.

· Save the edited file with the same name.

o Click Detect Settings to read and apply stage and galvo

settings from the XML file.

· Enable ACS  axes

· Apply settings from the XML file, it will automatically suggest
updating the stage and galvo parameters that do not match.

· Check the stage  configuration in Settings.

Note: Check the box Write syncAXIS Logs to log what commands
are sent to XL Scan.
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syncAXIS Configurator Window

Initializing XL SCAN: 

· Make sure RTC is available and connected to a scan head and syncAXIS Dongle is plugged in

· Try connecting  to the Hardware

· In Case of problems, check message in Error output window

· Refer to the syncAXIS Manual Troubleshooting chapter for more detailed description

First recipe with XL SCAN: 

· Define a recipe  you want to run

· Add Marking Parameters element to the start of the recipe (optional if marking parameters are defined in the command, there is no need to add them to the front) 

· Chose Scanner And Stage Motion type in the Marking Parameters .

· Set laser triggering parameters as well as jump and mark speeds for the process.

· Click Compile to see the laser path and Run to start the process.

· In case of problems during execution, check messages in SPC status bar or XL SCAN Logs menu in top ribbon.

· Refer to the ACS MMI Suite for description of problems with the mechanical axes

· Make sure the combined velocity of the motion is not too high

· Refer to the syncAXIS Manual Troubleshooting chapter for more detailed description

XL SCAN Simulation Mode: 

· Before commencing work flow you may want to run a simulation to make sure the dynamic limitations are not breached

· Process evaluation can be ran offline (all trajectories can be calculated offline before connecting to hardware) 

· DMC will highlight the values that are higher than settings set in DMC (stage and galvo dynamic parameters) and are only a recommendation.

· After simulation, the user can see and analyze the simulation data in syncAXIS Viewer.

XL SCAN Tools

syncAXIS Viewer: 

· Starts syncAXIS  Viewer, loads most recent simulation directly

· Refer to ScanLAB syncAXIS Viewer Manual

syncAXIS Configurator: 

· Starts syncAXIS Configurator, loads most recent configuration file directly

· Refer to syncAXIS Configuration Manual

XL SCAN Requisites: 

· DMC

· XLScan plugin.

XL SCAN Compatibility: 

· 3D trajectories with XL SCAN are unavailable. 2,5D processes are ok, for example 3D printing.

· Input monitoring during the trajectory execution/running recipe is unavailable.

· Data Monitoring feature in unavailable.

· External Start feature is unavailable.

· All RTC On Fly functionality is unavailable.

· Scanner Calibration feature works in a limited way. It is possible to generate the calibration file (by selecting Scanner Only in the Marking  parameters), but it is not uploaded automatically. The path to the
generated calibration file has to be added to the XL SCAN configuration file with the syncAXIS Configurator.

· Stitching  function works in a limited way. Only grid and object centering stitching can work if the Scanner Only mode is set in Marking  parameters.

12.8.1 XL SCAN Troubleshooting

Navigation:  How  To..?  >

XL SCAN Troubleshooting
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XL SCAN Troubleshooting

Log: 

Actions related to syncAXIS DLL are all laid out in the log. It can be a great troubleshooting tool for advanced customers and can aid ScanLAB work flows.

Error Pop-ups: 

The error pup-up relays information returned by the get_error function.
For further error description (especially if the error code is mentioned) refer to the syncAXIS Manual.

12.9 Table Calibration Tool

Navigation:  How  To..?  >

 Use Table Calibration Tool

Table Calibration Tool Dropdown Menu

Table Calibration Tool drop-down Menu has the following fields: 

· Controller – choose the controller that you would like to calibrate, it must move XY axes.

· Camera – choose the camera to use for pattern detection.

· X/Y Center Point – set the location that is the center of the calibration mask.

o We recommend finding the center point with the camera and press “Get Current Camera” button which should automatically set center position of

the calibration mask.

o Center point should be provided from the camera perspective if camera-laser offset exists. 

· X/Y Step – the step of the markings on the calibration mask or the measurement step.

o Would not recommend using different X and Y steps, because calculations might end in error and give bad results in calibration.

· Only if circular calibration mask:

o Set the Radius, if the mask is rectangular, ignore this parameter.

· Only if rectangular calibration mask:

o Set the Width.

o Set the Height.

Note: would not recommend using different width/height for the same reason as different X/Y steps size.

Note: it is recommended to use width and height such that width divided by the step size would be an odd number.

· Circular calibration artifact – only check if using a circular calibration mask. Leave unchecked in using rectangular mask.

· Example color – a color of predicted sample points.

· Show sample points – shows sample points where predicted points should be placed.

· Select Data File – select the file where the measurement errors are saved. If there is a need, the user can open file with the already measured points
and/or re-upload it/check average errors.

· Measured – shows where measured points were placed.

· Find points mode:

o Manual – all points must be detected manually.

o Advanced – uses machine vision for autofocus (if the camera is on Z axis) and pattern detection, finds errors automatically.

· Compensate Camera Offset – measured points are collected from laser perspective and when the “Compensate Camera Offset” is selected, it adds
camera offsets to the measurements. For example, if you want to check how it looks on the camera when the compensation is turned on.

 
View of the Table Calibration Tool

Example work flow:
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1. Connect to the hardware

2. With joystick and/or visual inspector go to calibration mask center

3. On table calibration plugin:

a. Press ‘Get Current Camera’ – center position of calibration would be set.

b. Set X/Y Step Size (size between measurement points or points on the mask). Preferably it should be same number.

c. If using circular mask – check “Circular Calibration Mask”, if rectangular – uncheck it.

d. Enter Radius if using circular mask or Width/Height if using rectangular. 

i. Width/Height preferably should be same size.

ii. If entering Width/Height – it is recommended to use Width and Height such that Width divided by Step size would be an odd number.

e. If you want to check how predicted (perfect) points compare to the measured points – you may click “Show sample points”.

i. It is recommended that the grid would be at least 3x3 size.

f. Select calibration file where you want to save data (or use default).

g. Select find points mode – manual or automatic.

i. If automatic – adjust the vision settings.

h. Press “Find points”.

4. Now the measurement has started – first two points selected would be placement error. Those would determine at which angle calibration mask is misplaced and correct further points.

5. Further points will determine the error – depending on the “find points mode”, selection points will be detected automatically, or the user must click on all of them manually.

6. After measurement is completed – you should see average and max error values.

a. “Error” is for the whole wafer error and “Error Inside” is excluding the border points. Border points usually have a significantly larger error.

7. After the measurement you can also “Browse Measured Errors”. After you click on it, the “Measurement data explorer” will pop up. In this table, you can see errors for each measurement. Clicking on the measured
coordinate will jump you to that location.

8. If you want to directly correct laser area – you should uncheck “compensate camera offset”, if you want, for example, to rerun the process and check how well it was compensated, has this checked.

9. Press Upload to Controller and depending on the controller creates a calibration file or uploads it directly to the controller.

10. If you want to rerun process – do not forget to rename file, otherwise it would be overwritten.

                                      

12.10 Keyence Sensor

Navigation:  How  To..?  >

Keyence Sensor

· First, make sure that the old Keyence sensor is disabled in DMC settings Keyence tab. Image above.
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· Go to Sensors tab and enable Sensor.

o Focus device: select Keyence CL-3000. It is made for this specific model, but many Keyence sensors are controlled

the same way.

§ Connection Mode: select either serial or TCP/IP, then chose appropriate connection settings.
§ OPTIONAL. Laser to Sensor Offset - since the sensor is often mounted with the offset from the laser, this offset should

be defined here:

o Offset X, Y is the offset is XY plane from the laser tool.

o Offset Z is physical distance between the lens (galvo/laser tool) and sensor lens.

§ Sensor Axis: chose the axis that the sensor is mounted on. 
§ Invert Measurement Value: select if the values do not match the axis direction. 
§ OPTIONAL. Probing Settings: these settings are used if the sensor is used as a probe. 
o Height Threshold: distance difference value that means the probe has reached the surface.

o Sensor Spot Size: beam spot size.

We suggest following this procedure to find the offsets.

1. Measure the distance between the laser lens and the sensor lens. For example, if the lens has a focus distance of 100 mm, and the sensor reading is 120 mm when the laser is in focus, the Z offset is

going to be 20 mm. Or alternatively, the user could set the Z offset as the sensor reading (for example 120 mm) and then the reading will be 0 at the laser focus position.

2. Make some cone engraving on the sample. This is needed to find the XY offset. Here is the example:

3. Set slicing, hatching, and marking parameters for it. Make sure to choose the appropriate size to be able to find it after engraving with the height sensor. And be sure to be in focus for the first slice.

4. Engrave the cone.

5. After engraving, using joystick, navigate the stages to move this engraving below the sensor. Try to find the tip of the cone with the sensor. At the tip of the cone note the X and Y stage position

values, these are going to be the X and Y offsets.

6. Go to Settings –> Keyence and for the calibration enter noted X, Y and Z values as offsets.

7. Offsets are now calibrated.

Sensor reading is going to be displayed near Positions. Clicking on the home button next to the sensor reading will set that position to 0 value. In other words, adds

an additional Z offset.

Z-map general tab works the same with all the Z find devices. To make Z-map operate with Keyence sensor go to Z Find tab. For the device please select the Sensor 1 -

Keyence…

Other parameters are irrelevant for the Keyence sensor as DMC will read the height data from the sensor at each point and use that data to construct the z-map.
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12.11 High Speed Height Data Collection

Navigation:  How  To..?  >

 Use Table Calibration Tool

High speed height data collection is based on reading stages position and analog input value from the motion controller at high speed. Usually motion controllers allow to synchronize collection of various signals at same
time, which allows to link analog value with position. 

To configure, create analog IO Tool in Settings->IO Tools->INPUTS. Define tool name, select “Type” to “Analog”, select which analog input device will be used
for analog input monitoring and click “Save”. 

In Settings->IO Tools->GENERAL tab select “Analog Device As” to “Depth Meter”, choose created analog IO Tool. “mm per V” value can be entered or
detected with “Detect” button (need to be connected to the hardware and be in height meter working range). 
Measurement Delay allows to define measurement and analog value reading delay which might be needed when scanning is done in positive and negative
X direction. 

Scanning can be done with ZMap command. ZMap command is located in “Recipe Flow” group. 

Filter Radius – Allows to define smooth kernel size to smooth analog input value the noise.
STL File – File where STL model needs to be saved after scanning is complete. 
Output File – File where raw position data will be saved

“Set Scan Area” button allows to define area where scanning needs to be done. This tool will fill “Position X”, “Position Y”, “Number of Points in X”,
“Number of Points in Y” fields. Before activating “Set Scan Area” tool, “Pitch X” and “Pitch Y” fields need to be defined. “Pitch X” value can be defined
small, because high speed scanning will be done in X direction. 

12.12 Grayscale Processing

Navigation:  How  To..?  >

 Grayscale Processing

Importing an Image: 

There are two options to import an image to DMC – as a 2D or 3D object.

Start by importing an image with the Import CAD button in the Home Tab. The image import window will pop up:
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Import Image Window

Select to import it as 2D image for raster scanning or a 3D image as an STL.

Define the size of an image. For 2D object the user can select to invert the image colors. For 3D object the user must select a smoothing filter size and whether the border is black or white.

The supported file types are: JPG, JPEG, PNG, BMP, TIF, TIFF.

Image Adjustment Command Properties

2D Object: 

Once imported, the object is displayed in the Preview Window.

In the Shape Tab of the Command Properties Window, the user can adjust the image and trajectory parameters:

· Invert Image color.

· Convert to Black and White.

· Adjust contrast and brightness.

· White Pixel level defines a threshold below which the pixel is interpreted as white and the laser will not fire at that location.

· Bidirectional – defines if scanning is in both or single direction.

· Direction if either Horizontal or Vertical.

· Grayscale Mode:

o Mark Non White Once – marks non white pixels only once if they are above white pixel level.

o Multiple Levels – divides the color value to the defined number of levels and will scan the image this defined number of times. During each scan only the

pixels above the level will fire.

o Multiple pulses – the level value sets the number of pulses that will be fired at the black pixel. Other pixels will result in the lower number of pulses

depending on the color value.

After the Shape parameters, the user should set Marking parameters and click Run to produce the part.

Note: if using a virtual galvo scanner controller in DMC, it has a limit (4000) of points in the line for raster scanning. Using the real hardware this limit is
depending on the hardware

Imported 3D Image

3D object

The image is imported as a 3D shape and converted to an STL format. The user then defines
slicing, hatching, and marking parameters to produce the shape.

If inversion is needed, in DMC there is an option to invert the shape.

With this, the user defines the outer shape and dimensions and  DMC automatically will
generate trajectories for the inverted shape.
More information about how to handle 3D objects is in the  DMC manual under Home
Tab  ->  Geometry  -> Import CAD  -> 3D Object .

12.13 Data Base Command

Navigation:  How  To..?  >

 Data Base Command

Setting up Data Base Command:

· Enable Data Base in General Settings  (F12). The following options should become available: 

Note: Currently Data Base Command supports 3 SQL databases: Microsoft Server, MySQL and PostGresSQL. 

· Fill out required details and click apply. 

Note: Data Source may or may not be required depending on the selected database.

Note: If there were errors connecting you will get an Error message, check your login details again.

Using the Data Base Command:

Data Base Command has the following Properties: 

Read Tab:

· Table - Select a table from the database in a drop-down menu. 

· Available Columns - A drop-down list of all the available columns. Add a column to Read Field by clicking on the columns name, formatting will be applied automatically.

· Columns To Read - A manual selection of comma separated columns to read is also possible. All columns can be selected by putting an asterisk (*) in this field.

21 22 23 24
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· Limit - number in this field indicates how many rows will be read from the top.

· Preview data - Click this button to view selected columns. This is especially useful for checking data in the database before reading or writing. 

· Variable name - When Recipe is running imported data will be imported as a Variable data array filled exactly the same as in the preview. You can use it in your recipes exactly the same as Variable data
array.

Write Tab:

· Table - Select a table you want to manipulate.

· Append - Select this option to add data to the top of the table.

Once “Table” is selected columns below are filled with appropriate column names. You can
fill all the data in the table.

· Replace - Select this option to replace a row’s column.

o Where Column - Select a column to search for the desired row.

o Has Value - Type the value of a column to search for the desired row.

o Replace Column - Select a column to replace the value.

o With Value - Type the value you want to replace the column with in found rows.

12.14 Two sets of XYZ Stages

Navigation:  How  To..?  >

 Two sets of XYZ Stages

Camera calibration:

· View position depends on - If the camera or the sample visible by the camera is moved by the stage, select Stage. If camera view is controlled via galvo scanner, select Galvo Scanner. 

Galvo Scanner:

· Camera correction file. If camera view goes via galvo scanner, camera correction file can be used to have more accurate camera view position (because laser and camera might need two different correction files
because of different wavelength). If camera correction file is set, camera correction file will be used when camera action is needed or recipe is not running. Marking correction file is activated automatically before
galvo scanner marking. 

· Show Position from Encoder - If checked, axis position is taken from real encoder. Only available for SCANLAB intelliSCAN and excelliSCAN.

· Acceleration (mm/s²) - Acceleration parameter is used only for time estimation. Approximate defalut value 10 8̂ (mm/s²)

· Position Depends On - Select which device moves galvo scanner XY position or sample XY position that can be marked by galvo scanner. When working zone is one, default value is Stage

· Z Position Depends On – Select which device moves galvo scanner Z position or sample Z position that can be marked by galvo scanner.  When working zone is one, default value is Stage

Laser Control:

· Laser Path Position Depends On – select which device(s) influence laser focus position on the sample. 
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13 Troubleshooting
Navigation:  »No topics above this level«

Troubleshooting

This section of the manual is a step by step guide for some of the functions in DMC software.
 

13.1 Event Viewer

Navigation:  »No topics above this level«

Event Viewer

In case the DMC software freezes or crashes but no error message is shown, it is possible to find the error message in the Even Viewer. 

To find the warning and error messages in the Event Viewer:

1. Right-Click the Start Menu icon to access the context menu. 

2. Open the Even Viewer and look for possible error or warnings. 
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14 Global Variables
Navigation:  »No topics above this level«

Global Variables

Global variables are created by DMC software automatically. They can be accessed in any formula or text input field.
 

Data Array Variable variable_name(column_no;row_n
o)

Gets value of a cell in a data array in Variable.

rows_count(variable_name) Returns number of rows in a Variable

columns_count(variable_name) Returns number of columns in a Variable

Position of axis pos(axis_name) Gets current position of a specific axis e.g. pos(x) gets current position of X axis. For galvo scanner axes use pos(gx/gy/gz) or pos(g2x/g2y/g2z)
when two or more galvo scanners are used.

Mouse position mpos.x Returns X position of the last mouse click on preview screen.

mpos.y Returns Y position of the last mouse click on preview screen.

Slicing slice_id Number of current slice.

slice_z Z position of current slice in mm.

slice_dz Distance between slices in mm.

Camera cam_offset(x) Laser to selected camera offset for X coordinate (value can be found in Settings->Camera->Calibration->…)

cam_offset(y) Laser to selected camera offset for Y coordinate (value can be found in Settings->Camera->Calibration->…)

cam_offset(z) Laser to selected camera offset for Z coordinate (value can be found in Settings->Camera->Calibration->…)

cam_offset(1;x) Laser to camera 1 offset for X coordinate (value can be found in Settings->Camera 1->Calibration->…)

cam_offset(2;x) Laser to camera 2 offset for X coordinate (value can be found in Settings->Camera 1->Calibration->…)

cam_offset(3;x) Laser to camera 3 offset for X coordinate (value can be found in Settings->Camera 1->Calibration->…)

cam_focus_value Returns the last measured best focus value for the camera (cam_focus_value1, cam_focus_value2, ...)

cam_focus_position Returns the last measured best focus position for the camera (cam_focus_position1, cam_focus_position2, ...)

Power Meter power Value of laser power from power meter (when power meter is configured).
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15 Mathematical Expressions
Navigation:  »No topics above this level«

Mathematical Expressions

DMC allows user to enter parameters using mathematical expressions.

Mathematical Formulas and Constants: 
 

Type Function Description

Algebraic
Formulas and
Functions

+, -, *, /, ^ Add, subtract, multiply, divide, exponent

<, >, =, >=, <= Less, more, equals, more or equal, less or equal

% Mod. value1%value2=value1-trunc(value1/value2)*value2

sqrt() Positive square root

abs() Returns absolute value

trunc() Returns integral part of specified value

round() ; round(value;digits) Rounds floating point to a specified number of digits or integer part if not specified.

min(value1;value2) ; min(value1;value2;value3) Returns minimum value of entered

max(value1;value2) ;
max(value1;value2;value3)

Returns maximum value of entered

ceil() Returns the smallest integral number that is greater or equal to specified

lg() Returns the base 10 logarithm of a specified value

ln() Returns the base e logarithm of a specified value

sign(value) Returns -1 if value is less than 0 and 1 if value is more than 0. Returns 0 if value is 0.

distance(x1;y1;x2;y2) distance between two points XY 

distance(x1;y1;z1;x2;y2;z2) distance between two points XYZ

equal(text1;text2) checks if the text is the same

equal({variable1};{variable2}) checks if the text in two variables are the same. Result: 0 or 1

Trigonometric
Functions

sin(value_in_degrees) Returns sine of specified angle in degrees

cos(value_in_degrees) Returns cosine of specified angle in degrees

tan(value_in_degrees) Returns tangent of specified angle in degrees

asin() Returns the angle (in degrees) whose sine is the specified value

acos() Returns the angle (in degrees) whose cosine is the specified value

atan() Returns the angle (in degrees) whose tangent is the specified value

atan2(value1;value2) Returns the angle whose tangent is the quotient of two specified numbers.

Unit
conversion

inch_to_mm() Converts inches to milimeters

mm_to_inch() Converts milimeters to inches

deg_to_rad() Converts degrees to radians

rad_to_deg() Converts radians to degrees

Numeric padding(number, decimal_places) returns number in text format with decimal_places number of symbols. If required, the number is padded with zeros to its left to produce the
number of digits given by the decimal_places variable value. E.g.: padding(123;6), will return result of: 000123

Constants pi 3.141592653589793238

e 2.71828182846
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16 Special Functions
Navigation:  »No topics above this level«

Special Functions

DMC allows user to enter parameters using special functions.

Special Functions: 

Logical If(condition;result if true;result if false) Condition is true if value is more than 0. Result can be any number or mathematical expression.

rand() Returns random number lower than specified value.

swap(variable_name1;variable_name2) Swaps values of two variables

Text get_length(variable_name) Calculates length of variable value (number of characters).

get_p(point_index;axis_name) Returns position of P position variable configured in Settings->Joystick. ‘point_index’ – 1,2,3,4; ‘axis_name’ - defined in Settings->Stages->Stage
Name field. If axis position is unchecked at Settings->Joystick, error will be returned.

set_p(point_index;axis_name;value) Sets value to joystick P position variables. point_index – 1,2,3,4; axis_name – axis name defined in Settings->Stages->Stage Name field; value –
position value to assign. If axis position is unchecked at Settings->Joystick, error will be returned.

get_row_index(variable_name;column_index;v
alue)

Returns the index of a row at which the value is the same as the third argument ‘value’.  If value is not found, -1 is returned.

set(variable_name;column_index;row_index;valu

e) 

Assign a value set in the fourth argument ‘value’ to a variable data array at colulmn ‘column_index’ and row ‘row_index’. 

substring(value;start_index;length) Retrieves a substring from ‘value’ text. The substring starts at a specified character position defined by ‘start_index’ and has a specified length
defined by ‘length’. Start index starts at 0. 

date(time_format) Returns the date. E.g. date(yyyy.nn.dd:oo.mm.ss)

Formula {} Text written within braces is interpreted as a formula / variable name. Braces are used where text input is needed. Braces are not needed in value
fields, e.g. variable value or position value is interpreted as a formula by default.

String equal({var1}; {var2}) Compares two strings. If var1 and var2 are equal strings, the function will return 1, otherwise 0.

Timing start_timer(index) Starts a timer with optional index parameter. Index range [1;10]. e.g.: start_timer(1)

elapsed(index) Returns time in seconds that passed since start_timer(index) function call. If index parameter is not defined, value 1 is used. e.g.: elapsed(1)

Camera cam_pos Returns camera view center position. E.g.: cam_pos(1, x)

cam_find_peak runs peak detection in camera view and saves the result to user defined variable. E.g. cam_find_peak(cam_index;variable_name) or
cam_find_peak(variable_name). 

Returns variable with following values: 

x - x position in mm
y - y position in mm
r - major radius in mm 
r1 - major radius in mm 
r2 - minor radius in mm 
ecc - eccentricity

Galvoscanner SET_GALVO galvo_index parameter value Set galvoscanner parameter value. The following parameters are available: offset_x, offset_y, scale_x, scale_y, angle. E.g.: SET_GALVO 1 angle
0.025

GET_GALVO galvo_index parameter Gets value of a chosen galvoscanner parameter. E.g.: GET_GALVO 1 angle

GALVO_APPLY_SETTINGS galvo_index Applies settings to a chosen galvoscanner. E.g. GALVO_APPLY_SETTINGS 1
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17 Support
Navigation:  »No topics above this level«

Support

For support on DMC software please contact support@directmachining.com
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